zoj-1221-Risk(最短路)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1221

Risk is a board game in which several opposing players attempt to conquer the world. The gameboard consists of a world map broken up into hypothetical countries. During a player's turn, armies stationed in one country are only allowed to attack only countries with which they share a common border. Upon conquest of that country, the armies may move into the newly conquered country.

During the course of play, a player often engages in a sequence of conquests with the goal of transferring a large mass of armies from some starting country to a destination country. Typically, one chooses the intervening countries so as to minimize the total number of countries that need to be conquered. Given a description of the gameboard with 20 countries each with between 1 and 19 connections to other countries, your task is to write a function that takes a starting country and a destination country and computes the minimum number of countries that must be conquered to reach the destination. You do not need to output the sequence of countries, just the number of countries to be conquered including the destination. For example, if starting and destination countries are neighbors, then your program should return one.

The following connection diagram illustrates the sample input.


Input

Input to your program will consist of a series of country configuration test sets. Each test set will consist of a board description on lines 1 through 19. The representation avoids listing every national boundary twice by only listing the fact that country I borders country J when I < J. Thus, the Ith line, where I is less than 20, contains an integer X indicating how many "higher-numbered" countries share borders with country I, then X distinct integers J greater than I and not exceeding 20, each describing a boundary between countries I and J. Line 20 of the test set contains a single integer (1 <= N <= 100) indicating the number of country pairs that follow. The next N lines each contain exactly two integers (1 <= A,B <= 20; A!=B) indicating the starting and ending countries for a possible conquest.

There can be multiple test sets in the input; your program should continue reading and processing until reaching the end of file. There will be at least one path between any two given countries in every country configuration.


Output

For each input set, your program should print the following message "Test Set #T" where T is the number of the test set starting with 1. The next NT lines each will contain the result for the corresponding test in the test set - that is, the minimum number of countries to conquer. The test result line should contain the start country code A the string " to " the destination country code B ; the string ": " and a single integer indicating the minimum number of moves required to traverse from country A to country B in the test set. Following all result lines of each input set, your program should print a single blank line.


Sample Input

1 3 
2 3 4 
3 4 5 6 
1 6 
1 7 
2 12 13 
1 8 
2 9 10 
1 11 
1 11 
2 12 17 
1 14 
2 14 15 
2 15 16 
1 16 
1 19 
2 18 19 
1 20 
1 20 

1 20 
2 9 
19 5 
18 19 
16 20


Sample Output

Test Set #1 
1 to 20: 7 
2 to 9: 5 
19 to 5: 6 
18 to 19: 2 
16 to 20: 2 

题目大意:20个城市,每个城市之间有双向道路,前19行是1~19个ch城市相连通的道路,n个道路,输入n个城市,

接下来是一个m表示m次查找,查找两个城市之间的最短的距离,

一道水题,数据太少了,主要是格式一直错误。。还有需要重复输入(虽然从样例中看不出来。。)随便写写,就用堆优化一下把,就当熟悉了;

ac:

#include<stdio.h>
#include<string.h>  
#include<math.h>  
  
//#include<map>   
//#include<set>
#include<deque>  
#include<queue>  
#include<stack>  
#include<bitset> 
#include<string>  
#include<iostream>  
#include<algorithm>  
using namespace std;  

#define ll long long  
#define INF 0x3f3f3f3f  
#define mod 1000000007
#define clean(a,b) memset(a,b,sizeof(a))// 水印 
struct node{
	int num,l;
	node(int _num=0,int _l=0):num(_num),l(_l){}
};

struct cmp{
	bool operator()(const node &x,const node &y){
		return x.l>y.l;
	}
};
vector<node> rode[25];
int d[25];
bool vst[25];

void djstr(int str,int ed)
{
	clean(vst,0);
	clean(d,INF);
	priority_queue<node,vector<node>,cmp> que;
	while(que.size())
		que.pop();
	que.push(node(str,0));
	d[str]=0;
	while(que.size())
	{
		node now=que.top();
		que.pop();
		if(now.num==ed||vst[now.num])
		{
			//cout<<now.num<<" "<<ed<<" "<<vst[now.num]<<" ";
			break;
		}
		vst[now.num]=1;
		for(int i=0;i<rode[now.num].size();++i)
		{
			node e=rode[now.num][i];
			if(!vst[e.num]&&d[e.num]>d[now.num]+e.l)
			{
				d[e.num]=d[now.num]+e.l;
				que.push(node(e.num,d[e.num]));
			}
		}
	}
}

int main()
{
	int cnt=1;
	int x;
	while(scanf("%d",&x)!=EOF)
	{
		for(int i=0;i<25;++i)
			rode[i].clear();
		for(int j=0;j<x;++j)
		{
			int num;
			cin>>num;
			rode[1].push_back(node(num,1));
			rode[num].push_back(node(1,1));
		}
		for(int i=2;i<20;++i)
		{
			int n;
			cin>>n;
			for(int j=0;j<n;++j)
			{
				int num;
				cin>>num;
				rode[i].push_back(node(num,1));
				rode[num].push_back(node(i,1));
			}
		}
		int m;
		cin>>m;
		cout<<"Test Set #"<<cnt++<<endl; 
		for(int i=0;i<m;++i)
		{
			int a,b;
			cin>>a>>b;
			djstr(a,b);
			//printf("%d to %d: %d\n",a,b,d[b]);
			cout<<a<<" to "<<b<<": "<<d[b]<<endl;
		}
		cout<<endl;
	}
	
}
/*
1 3 
2 3 4 
3 4 5 6 
1 6 
1 7 
2 12 13 
1 8 
2 9 10 
1 11 
1 11 
2 12 17 
1 14 
2 14 15 
2 15 16 
1 16 
1 19 
2 18 19 
1 20 
1 20 
5 
1 20 
2 9 
19 5 
18 19 
16 20
*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值