HDU 1018 Big Number 【暴力】【斯特林公式】

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43485    Accepted Submission(s): 21282

Problem Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2

10

20

Sample Output

7 19

Source

Asia 2002, Dhaka (Bengal)

Recommend

JGShining

题意:

给你一个数,让你求出N!由多少位数构成,比如输出10,它的阶乖是3628800 由7位数构成,这时你要输出7

分析:

方法1:暴力求解

10^m=a,a的位数为m+1,(int)log10(a)+1就是a的位数

log10(n!)=log10(1*2*3*4.......*(n-1)*n)=log10(1)+log10(2)+log10(3)+log10(4)+.......+log10(n)

n!的位数为 floor(log(n!))+1

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e7+7;
typedef long long LL;
//double num[maxn];//内存超限

int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        double ans=0.0;
        for(int i=1;i<=n;i++)
        ans+=log10(i);
        printf("%d\n",(int)ans+1);
    }
}

方法二:斯特林公式

利用Stirling公式计算n!结果的位数时,可以两边取对数(底数为e),得: 

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e7+7;
typedef long long LL;
//double num[maxn];
#define e 2.71828
#define pi acos(-1)
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        double ans=0.0;
        ans=log10(2.0*pi*n)/2+n*(log10(n)-1/log(10));
        printf("%d\n",(int)ans+1);
    }
}
//10000000

方法三:java大数【超时】

import java.util.*;
import java.math.*;

public class Main{
	
	public static void main(String[] args){
		Scanner cin=new Scanner(System.in);
		int T=cin.nextInt();
		while((T--)!=0) {
			int n=cin.nextInt();
			BigInteger ans=BigInteger.ONE;
			for(int i=1;i<=n;i++) {
				ans=ans.multiply(BigInteger.valueOf(i));
			}
			System.out.println(ans.toString().length());
		}
		cin.close();
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值