HDU-1018-Big Number(数学)

Big Number

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input

2
10
20

Sample Output

7
19

题目大意: t组输入,输入一个数n,输出这个数的阶乘的位数。

解题思路:
如果先计算出阶乘,再计算位数会超时。就像这样:

//error:Time Limit Exceeded
int n;
cin>>n;
a[0]=1;
int ans=1;				//位数
int k=0;
for(int i=1; i<=n; i++)
{

    for(int j=0; j<ans; j++)
    {
        a[j]=a[j]*i+k;
        k=a[j]/10;
        a[j]%=10;
        if(j==ans-1&&k!=0)
        {
            ans++;
        }
    }
}
cout<<ans<<endl;

所以只能用另一种方法计算位数。在这之前,我们必须要知道一个知识,任意一个正整数a的位数
等于(int)log10(a) + 1;可以将这道题理解为一道数学题,运用这个公式。
也就是说:
n的阶乘的位数等于:

(int)(log10(1)+log10(2)+log10(3)+......+log10(n)) + 1

完整代码:

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        double ans=0.0;					//位数
        for(int i=1; i<=n; i++)			//也可以从i=2开始循环,因为log10(1)=0。
            ans+=log10(i);
        cout<<int(ans)+1<<endl;
    }
    return 0;
}

原题链接:
HUD-1018-Big Number
vjudge-HUD-1018-Big Number


补充:
之前的超时代码(先计算出数的阶乘,再计算出阶乘的位数):

#include<iostream>
#include<cmath>
using namespace std;
int a[100000];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        a[0]=1;
        int ans=1;
        int k=0;
        for(int i=1; i<=n; i++)
        {

            for(int j=0; j<ans; j++)
            {
                a[j]=a[j]*i+k;
                k=a[j]/10;
                a[j]%=10;
                if(j==ans-1&&k!=0)
                {
                    ans++;
                }
            }
        }
        cout<<ans<<endl;

    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值