POJ3061 Subsequence   尺取法(双指针)

Subsequence    

POJ - 3061 

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:

给以一个正整数序列,求一个长度最短的连续子序列,并使该序列的和,大于等给定正整数S,输出最短子序列的长度

区间【5,10】

区间【4,15】 

 总结算法:

  1. 当前区间和小于S时,右端点右移
  2. 当前区间和大于等于S时,左端点右移

尺取法:通过移动左右两个端点,遍历一个序列,求得最短区间的算法;

时间复杂度O(n);

应用尺取法求解问题有两个特征:

  1. 问题的答案是满足某个条件的最短连续序列,或区间
  2. 任意两个合法区域(满足题目要求的区间)[a,b]  ,  [c,d] ,若a>c,必有d>=b
 
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;
int a[maxn];
int n,s;//n个元素,元素和S
int ruler()
{
    int left=0,right=0;//双指针
    int len=n+1;//和大于等于S的最短序列长度
    int sum=0;//元素和
        while(1){
        while(right<n&&sum<s)
            sum+=a[right++];
            if(sum<s)   break;//已经到最后一个元素
            len=min(len,right-left);//更新最小值
            sum-=a[left++];
        }
      return len;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&s);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
    int res=ruler();
    if(res<n+1) printf("%d\n",res);
    else    printf("0\n");//不存在
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值