HDU1257 考验思维的LIS

Sample Input

8 389 207 155 300 299 170 158 65

Sample Output

2

没看题解前,我的思路和这位博主的思路几乎一样,但越写越复杂,总觉得不对劲,只好看一眼题解,发现居然是LIS!

不看题解的话,还真是想不出来,先写下来慢慢悟吧

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <bitset>
using namespace std;

#define LL          long long
#define ZERO(a)     memset(a,0,sizeof(a))

const LL INF = 0x3f3f3f3f;
const int mod = 1e9+7;
const int maxn =  3e4+10;

int a[maxn];
int dp[maxn];

int main()
{
    int n;
    while(~scanf("%d",&n)){
        for(int i=1; i<=n; ++i) scanf("%d",&a[i]);
        ZERO(dp);

        int ans = 0;
        for(int i=1; i<=n; ++i){
            dp[i] = 1;
            for(int j=1; j<i; ++j){
                if(a[j] < a[i]){
                    dp[i] = max(dp[i], dp[j]+1);
                }
            }
            ans = max(ans, dp[i]);
        }
        printf("%d\n",ans);
    }

    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值