1151 LCA in a Binary Tree (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

 

方法一:

递归

这种方法非常直观。先深度遍历改树。当你遇到节点 p 或 q 时,返回一些布尔标记。该标志有助于确定是否在任何路径中找到了所需的节点。最不常见的祖先将是两个子树递归都返回真标志的节点。它也可以是一个节点,它本身是p或q中的一个,对于这个节点,子树递归返回一个真标志。

让我们看看基于这个想法的形式算法。

算法:

  1. 从根节点开始遍历树。
  2. 如果当前节点本身是 p q 中的一个,我们会将变量 mid 标记为 true,并继续搜索左右分支中的另一个节点。
  3. 如果左分支或右分支中的任何一个返回 true,则表示在下面找到了两个节点中的一个。
  4. 如果在遍历的任何点上,左、右或中三个标志中的任意两个变为 true,这意味着我们找到了节点 pq 的最近公共祖先

转载LeetCode链接:点我有惊喜(⊙o⊙)?

#include <bits/stdc++.h>
using namespace std;
vector<int> pre, in, tempPath;
map<int, bool> mp;

struct Node {
	int val;
	Node *left, *right;
	Node(int x) {
		this -> val = x;
		this -> left = this -> right = NULL;
	}
};

Node *create(int preL, int preH, int inL, int inH) {
	if (preL > preH) {
		return NULL;
	}
	Node *root = new Node(pre[preL]);
	int k;
	for (k = inL; in[k] != pre[preL]; k++);
	int leftNum = k - inL;
	root -> left = create(preL+1, preL+leftNum, inL, inL+leftNum-1);
	root -> right = create(preL+leftNum+1, preH, inL+leftNum+1, inH);
	return root;
}

int res;

bool LCA(Node *root, int p, int q) {
	if (root == NULL) return false;
	int l = LCA(root -> left, p, q) ? 1:0;
	int r = LCA(root -> right, p, q) ? 1:0;
	int m = (root -> val == p || root -> val == q) ? 1 : 0;
	if (l+r+m >= 2) res = root -> val;
	return (l+r+m > 0 ? 1:0);
}

int main() {
	int n, k, u, v;
	cin >> k >> n;
	pre.resize(n);
	in.resize(n);
	
	for (int i = 0; i < n; i++) {
		cin >> in[i];
		mp[in[i]] = true;
	}
	for (int i = 0; i < n; i++) {
		cin >> pre[i];
	}
	Node *root = create(0, n-1, 0, n-1);
	for (int i = 0; i < k; i++) {
		cin >> u >> v;
		if (!mp[u] && !mp[v]) {
			printf("ERROR: %d and %d are not found.\n", u, v);
		} else if (!mp[u] && mp[v]) {
			printf("ERROR: %d is not found.\n", u);
		} else if (mp[u] && !mp[v]) {
			printf("ERROR: %d is not found.\n", v);
		} else {
			if (u == v) {
				res = u;
			} else {
				LCA(root, u, v);
			}
			if (res != u && res != v) {
				printf("LCA of %d and %d is %d.\n", u, v, res);
			} else if (res != u && res == v) {
				printf("%d is an ancestor of %d.\n", res, u);
			} else if (res == u && res != v) {
				printf("%d is an ancestor of %d.\n", res, v); 
			} else {
				printf("%d is an ancestor of %d.\n", res, v); 
			}
		}
	}
	return 0;
}

方法二:

建树的时候设置其节点之间的双亲和孩子的关系,先找到给定两个给定值的节点,通过递推双亲节点,找到两条到根节点的路径(用vector存储)然后从后往前比较,最后一个相等的节点即为LCA。

#include<bits/stdc++.h>
using namespace std;
vector<int> in, pre;

struct Node {
	int val;
	Node *left, *right, *parent;
	Node(int x):val(x), left(NULL), right(NULL), parent(NULL) {}
};

map<int, bool> mp; 
Node *root = NULL;

Node *create(int preL, int preH, int inL, int inH) {
	if (preL > preH) {
		return NULL;
	}
	Node *root = new Node(pre[preL]);
	int k;
	for (k = inL; in[k] != pre[preL]; k++);
	int leftNum = k - inL;
	root -> left = create(preL+1, preL+leftNum, inL, inL+leftNum-1);
	root -> right = create(preL+leftNum+1, preH, inL+leftNum+1, inH);
	if (root -> left != NULL) root -> left -> parent = root;
	if (root -> right != NULL) root -> right -> parent = root;
	return root;
}

void search(Node *root, Node *&res, int x) {
	if (root != NULL) {
		if (root -> val == x) {
			res = root;
		}
		search(root -> left, res, x);
		search(root -> right, res, x);
	}
}

int LCA(int p, int q) {
	Node *pNode = NULL, *qNode = NULL;
	search(root, pNode, p);
	search(root, qNode, q);
	vector<int> pv, qv;
	while (pNode != NULL) {
		pv.push_back(pNode -> val);
		if (pNode -> val == root -> val) {
			break;
		}
		pNode = pNode -> parent;
	}
	while (qNode != NULL) {
		qv.push_back(qNode -> val);
		if (qNode -> val == root -> val) {
			break;
		}
		qNode = qNode -> parent;
	}
	int i = pv.size()-1, j = qv.size()-1;
	while (i >= 0 && j >= 0) {
		if (pv[i] != qv[j]) {
			return pv[i+1];
		}
		i--, j--;
	}
	// 处理这种情况
	// pv = {6, 7, 8}
	// qv = {7, 8} 
	if (i == -1) return pv[0];
	if (j == -1) return qv[0];
}

int main() {
	int k, n, u, v;
	cin >> k >> n;
	in.resize(n);
	pre.resize(n);
	for (int i = 0; i < n; i++) {
		cin >> in[i];
		mp[in[i]] = true;
	}
	for (int i = 0; i < n; i++) {
		cin >> pre[i];
	}
	root = create(0, n-1, 0, n-1);
	for (int i = 0; i < k; i++) {
		cin >> u >> v;
		if (!mp[u] && !mp[v]) {
			printf("ERROR: %d and %d are not found.\n", u, v); 
		} else if (!mp[u] && mp[v]) {
			printf("ERROR: %d is not found.\n", u); 
		} else if (mp[u] && !mp[v]) {
			printf("ERROR: %d is not found.\n", v); 
		} else {
			int res = LCA(u, v);
			if (res != u && res != v) {
				printf("LCA of %d and %d is %d.\n", u, v, res); 
			} else if (res == u && res != v) {
				printf("%d is an ancestor of %d.\n", res, v);
			} else if (res != u && res == v) {
				printf("%d is an ancestor of %d.\n", res, u);
			} else {
				printf("%d is an ancestor of %d.\n", res, res); 
			}
		}
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值