PAT甲级1009

1009 Product of Polynomials (25point(s))

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

题目大意:给出两个多项式,求A*B,跟PAT1002类似,只不过这个是求乘法。
解题思路:简单模拟即可。

Java代码:

import java.text.DecimalFormat;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		double poly1[] = new double[1001];
		double poly2[] = new double[1001];
		double poly3[] = new double[2001];
		int e, num = 0;
		double c;
		Scanner sc = new Scanner(System.in);
		int first = sc.nextInt();
		for(int i=0; i<first; i++)
		{
			e = sc.nextInt();
			c = sc.nextDouble();
			poly1[e] = c;
		}
		int second = sc.nextInt();
		for(int i=0; i<second; i++)
		{
			e = sc.nextInt();
			c = sc.nextDouble();
			poly2[e] = c;
		}
		for(int i=0; i<1001; i++)
		{
			for(int j=0; j<1001; j++)
			{
				if(poly1[i] * poly2[j] != 0) {
					poly3[i+j] += poly1[i] * poly2[j];
				}
			}
		}
		for(int i=0; i<2001; i++)
		{
			if(poly3[i]!=0)
				num++;
		}
		System.out.print(num);
		DecimalFormat df = new DecimalFormat("0.0");
		for(int i=2000; i>=0; i--)
		{
			if(poly3[i]!=0) {
				System.out.print(" " + i + " " + df.format(poly3[i]));
			}
		}
	}
}

C++代码:

#include <bits/stdc++.h>
using namespace std;
    double poly1[1001];
    double poly2[1001];
    double poly3[2001];

int main(){
    int first,second,e,num,i,j;
    num=0;
    scanf("%d",&first);
    for(i=0; i<first; i++){
        scanf("%d",&e);
        scanf("%lf",&poly1[e]);
    }
    scanf("%d",&second);
    for(i=0; i<second; i++){
        scanf("%d",&e);
        scanf("%lf",&poly2[e]);
    }
    for(i=0; i<1001;i++){
        for(j=0; j<1001; j++){
            if(poly1[i]*poly2[j]!=0){
                poly3[i+j]+=poly1[i]*poly2[j];
            }
        }
    }
    for(i=0; i<2001; i++){
        if(poly3[i]!=0){
            num++;
        }
    }
    printf("%d",num);
    for(i=2000; i>=0;i--){
        if(poly3[i]!=0){
            printf(" %d %.1lf",i,poly3[i]);
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值