【2017广西邀请赛】hdu 6182 A Math Problem

Problem Description
You are given a positive integer n, please count how many positive integers k satisfy  kkn .
 

Input
There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

1n1018
 

Output
For each test case, output an integer indicates the number of positive integers k satisfy  kkn  in a line.
 

Sample Input
  
  
1 4
 

Sample Output
  
  
1 2
 

暴力枚举

//
//  main.cpp
//  A
//
//  Created by zc on 2017/9/6.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define ll long long 
using namespace std;

ll n;

int main(int argc, const char * argv[]) {
    while(~scanf("%lld",&n))
    {
        int ans=0;
        for(int i=1;i<=15;i++)
        {
            ll sum=1;
            for(int j=1;j<=i;j++)
            {
                sum*=(ll)i;
            }
            if(sum<=n)  ans++;
            else    break;
        }
        printf("%d\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值