HDU - 4004 The Frog's Games (二分)

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

 

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

 

Output

For each case, output a integer standing for the frog's ability at least they should have.

 

Sample Input

6 1 2
2
25 3 3
11 
2
18

 

Sample Output

4
11

题目大意:青蛙过河,河宽L,河中石头数n,最大跳跃次数m,每次跳跃落地点只能是石头上和岸边,求最少每次跳多少米, 

解题思路:记录石头位置时,多记录两岸的距离,一个为0,一个为L,多建立一个数组,记录n个石头间的距离,,在求解记录中设一个变量maxd,用来保存相邻石头间的最大距离,然后使用二分求解最小跳跃距离,则二分区间为[maxd,l],

AC代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=5e5+10;
int L,m,n,a[maxn],b[maxn];
bool solve(int ans)
{
	int sum=0;
	int k=1;
	for(int i=0;i<=n;i++)
	{
		sum+=b[i];
		if(sum>ans)//前i个石头的距离比跳跃能力大,青蛙就落在第i-1个石头上 
		{
			k++;//跳跃次数加一 
			sum=b[i];//然后从第i-1个 石头跳到第i个石头上 
		}
	}
	if(k>m)
		return false;
	else
		return true; 
}
void bin(int l,int r)//二分查找 
{
	while(l<r)
	{
		int mid=(l+r)/2;
		if(solve(mid))
			r=mid;
		else
			l=mid+1;
	}
	cout<<r<<endl;	
}
int main()
{
	std::ios::sync_with_stdio(false);
	while(cin>>L>>n>>m)
	{
		a[0]=0;
		for(int i=1;i<=n;i++)
			cin>>a[i];
		a[n+1]=L;
		sort(a,a+1+n+1);
		int maxd=0;
		for(int i=0;i<n+1;i++)
		{
			b[i]=a[i+1]-a[i];//两个石头之间的最大距离
			maxd=max(maxd,b[i]); 
		}
		if(m>n)//跳跃次数比石头多,最小跳跃能力就是相邻石头间的最大距离 
			cout<<maxd<<endl;
		else	
			bin(maxd,L);	
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值