Problem G: STL——Jerry的问题

Problem G: STL——Jerry的问题

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 4001   Solved: 2516
[ Submit][ Status][ Web Board]

Description

最近Jerry正在刻苦的学习STL中的set的功能函数,他发现set可以用现有的函数实现并、交、差、对称差等功能,但是他没有找到怎么来比较两个集合是否相等的功能函数,所以他想自己用其他的功能函数来实现能判断两个集合是否相等的功能函数。聪明的Jerry不一会就想到了解决办法,现在他想拿这道题来考考你,看你有没有他聪明。

Input

输入有多组,每组数据有两行,每一行都代表一个集合,每一行有若干个正整数(0<d<=2147483647),并且每行的最后一个数字都是0,代表该行数据的结束,且末尾的0不计入集合中。最后以EOF结束输入。

Output

对于每组数据输出都要输入一个结果,如果两个集合相等便输出“YES”,否则输出“NO”,每个结果占一行

Sample Input

1 2 3 4 01 2 3 4 01 2 2 2 2 2 01 2 01 2 3 4 01 3 3 4 0

Sample Output

YESYESNO

HINT

对称差运算:得到的结果是第一个集合与第二个集合的差集并上第二个与第一个的差集


Append Code

[ Submit][ Status][ Web Board]
?
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
#include <iostream>
#include <algorithm>
#include <set>
#include <iterator>
using namespace std;
 
int main()
{
     set<unsigned long long >A,B,AB;
     unsigned long long n;
     while ((cin>>n)!=NULL)
     {
         A.clear();
         B.clear();
         AB.clear();
         if (n!=0)
         {
             while (1)
     {
             A.insert(n);
                 cin>>n;
             if (n==0) break ;
     }
          }
             while (1)
        {
             cin>>n;
            if (n==0) break ;
             B.insert(n);
         }
             set_difference(A.begin(),A.end(),B.begin(),B.end(),inserter(AB,AB.begin()));
             if (AB.empty())
                 cout<< "YES" <<endl;
             else
                 cout<< "NO" <<endl;
 
     }
     return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值