Problem A: 分数类的输出
Time Limit: 3 Sec Memory Limit: 128 MBSubmit: 4718 Solved: 2055
[ Submit][ Status][ Web Board]
Description
封装一个分数类Fract,用来处理分数功能和运算,支持以下操作:
1. 构造:传入两个参数n和m,表示n/m;分数在构造时立即转化成最简分数。
2. show()函数:分数输出为“a/b”或“-a/b”的形式,a、b都是无符号整数。若a为0或b为1,只输出符号和分子,不输出“/”和分母。
-----------------------------------------------------------------------------
你设计一个Fract类,使得main()函数能够运行并得到正确的输出。调用格式见append.cc
Input
输入多行,每行两个整数,分别为分子和分母,至EOF结束。输入的分母不会为0;
Output
每行输出一个分数,与输入顺序一致。
分数输出时为最简形式,负号只会出现在最前面,若分母为1或分子为0,则只输出一个整数,即分子部分,而没有“/”和分母部分。
Sample Input
1 320 -1580 150-9 16 612 16-33 -486 110 -10
Sample Output
1/3-4/38/15-913/411/166/110
HINT
Append Code
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
|
#include <bits/stdc++.h>
using
namespace
std;
class
Fract
{
private
:
int
m , n ;
public
:
Fract(
int
a,
int
b):m(a),n(b)
{
int
nn=m>n?n:m;
int
mm=m>n?m:n;
int
t;
if
(nn>0)
{
for
(
int
i = 1 ; i <= nn;i++)
{
if
(nn%i==0&&mm%i==0)
t=i;
}
}
else
if
(nn<0)
{
for
(
int
i = -1 ;i >= nn ;i--)
{
if
(nn%i==0&&mm%i==0)
t=-i;
}
}
if
(n<0)
{
m=-m;n=-n;
}
if
(t!=1)
{
m=m/t;
n=n/t;
}
}
void
show()
{
if
(m==0||n==1)
{
cout<<m<<endl;
}
else
{cout<<m<<
"/"
<<n<<endl;}
}
};
#include <cstdio>
int
main()
{
int
n, m;
while
(cin >> n >> m)
{
Fract fr(n, m);
fr.show();
}
}
|