werewolf

Werewolf

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1141    Accepted Submission(s): 310

Problem Description

"The Werewolves" is a popular card game among young people.In the basic game, there are 2 different groups: the werewolves and the villagers.

Each player will debate a player they think is a werewolf or not. 

Their words are like "Player x is a werewolf." or "Player x is a villager.".

What we know is :

1. Villager won't lie.

2. Werewolf may lie. 

Of cause we only consider those situations which obey the two rules above. 

It is guaranteed that input data exist at least one situation which obey the two rules above.

Now we can judge every player into 3 types :

1. A player which can only be villager among all situations, 

2. A player which can only be werewolf among all situations.

3. A player which can be villager among some situations, while can be werewolf in others situations.

You just need to print out the number of type-1 players and the number of type-2 players. 

No player will talk about himself.

 Input

The first line of the input gives the number of test cases T.Then T test cases follow.

The first line of each test case contains an integer N,indicating the number of players.

Then follows N lines,i-th line contains an integer x and a string S,indicating the i-th players tell you,"Player x is a S."

limits:

1≤T≤10

1≤N≤100,000

1≤x≤N

S∈ {"villager"."werewolf"}

Output

For each test case,print the number of type-1 players and the number of type-2 players in one line, separated by white space.

Sample Input

1 2 2 werewolf 1 werewolf

Sample Output

0 0


题意:狼人杀游戏有两种身份,一种是狼人,一种是平民,其中狼人可以说谎,平民说的都是实话。

其中指认狼人为平民的都为狼人。

#include <bits/stdc++.h>

using namespace std;

int b[1000005];
bool iswolf[1000005];

struct node{
	vector<int>ve;
	int kind;
	int next;
	
}q[100004];

int change (int x){ //
	int y = x;
	while(b[x] != x){
		x = b[x];
	}
	while(y != b[y]){
		int t = b[y];
		b[y] = x;
		y = x; 
	}
	return x;
}

void bing(int x,int y){
	int p= change(x);
	int q = change(y);
	if(p != q)
		b[p] = b[q]; 
}

//find
void dfs(int num){
	iswolf[num] = true;
	if(q[num].ve.size() == 0) //empty
		return ;
	int len = q[num].ve.size();
	for(int i=0;i<len;i++){
		dfs(q[num].ve[i]);
	}
}

int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			b[i] = i;
		for(int i=0;i<n;i++){
			q[i+1].ve.clear() ; 
		}
		for(int i=0;i<n;i++){
			//q[i].id = i+1;
			char y[10];
			scanf("%d %s",&q[i+1].next,y);
			if(y[0] == 'w')
				q[i+1].kind = 1;
			else{
				q[i+1].kind = 0;
				bing (i+1,q[i+1].next);//b[i+1] = b[q[i+1].next
				q[q[i+1].next].ve.push_back(i+1);   //add
			}							
		}
		memset(iswolf,false,sizeof(iswolf));
		for(int i=0;i<n;i++){
			if(q[i+1].kind == 1){
				int num  = q[i+1].next;
				if(change(num) == change(i+1))
					dfs(num); 
			}
		}
		int cnt = 0;
		for(int i=1;i<=n;i++){
			if(iswolf[i])
				cnt++;
		}
		printf("0 %d\n",cnt);
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值