题目要求:
我们学院经常组织各项技能比赛,例如电脑文化节中Flash作品比赛,台下有10位评委来评判参赛者的作品,评委打分:0-100分的整数,参赛者最终得分是去掉一个最高分,去掉一个最低分,所剩分数的平均分。
要求设计一个软件,可以连续输入10位评委的成绩,并且可以无限次计算参赛者的成绩(提示,不退出即可继续输入下一批成绩)
输入格式:
90 100 80 70 65 86 77 89 91 73
输出格式:
100 65 82
输入样例:
在这里给出一组输入。例如:
90
100
80
70
65
86
77
89
91
73
输出样例:
在这里给出相应的输出。例如:
100 65
82
实现:
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
while(true){
int[] score = new int[10];
for (int i=0;i<score.length;i++){
score[i] = scan.nextInt();
}
int min=score[0],max=score[0];
for(int i=1;i<score.length;i++){
if (score[i]>max){
max = score[i];
}
if (score[i]<min){
min = score[i];
}
}
System.out.println(max + " " + min);
for(int i=1;i<score.length;i++){
if (score[i] == max){
score[i] = 0;
}
if (score[i] == min){
score[i] = 0;
}
}
int sum=0;
for(int a:score){
sum += a;
}
System.out.println(sum/8);
}
}
}