4-2 电子时钟中的运算符重载

4-2 电子时钟中的运算符重载
Time Limit: 1000MS Memory Limit: 65536KB
Submit Statistic
Problem Description

通过本题目的练习可以运算符重载的方法;
设计一个时间类Time,私有数据成员有hour(时)、minute(分)、second(秒);
公有成员函数有:setHour(int)设置数据成员hour的值,非法的输入默认为12;setMinue(int)设置数据成员minute的值,非法输入默认为0;setSecond(int)设置数据成员second的值,非法输入默认为0;setTime(int,int,int)设置时、分、秒三个数据成员的值;三个成员函数int getHour(); int getMinute(); int getSecond();分别用于获取时间对象的属性值。
定义两个构造函数Time(); 和 Time(int,int,int);
定义一个成员函数void displayTime(); 用于显示时间,注意格式为 hh:mm:ss,位数不够用0填充;
定义一个时钟增加1的成员函数 void tick(); 把second的值加1,并注意是否到60;
定义一个成员或友元函数 bool operator= =(….); 判断两个时间对象的值是否相等;
定义一个成员或友元函数bool operator>(…..); 判断第一个时间对象的值是否大于第二个时间对象的值。

在主函数main()中指定开始时间和结束时间,并调用相应成员函数,显示从开始时间到结束时间之间所有时间对象的值,其格式见示例输出。
Input

输入6个整数,之间用一个空格间隔;分别表示开始时间的时、分、秒和结束时间的时、分、秒的值
Output

从开始时间到结束时间之间所有时间对象的值;每个值占一行,格式为hh:mm:ss
Example Input

01 01 01 01 01 10
Example Output

01:01:01
01:01:02
01:01:03
01:01:04
01:01:05
01:01:06
01:01:07
01:01:08
01:01:09
01:01:10
Hint

输入
11 10 12 10 12 56
输出
The begin time is not earlier than the end time!
Author

黄晶晶

#include<iostream>
#include<cstdio>
#include<cstdio>
using namespace std;
class Time
{
private:

public:
    int hour,minute,second;
    Time() {}
    Time(int h,int m,int s);
    void dispiayTime();
    friend bool operator==(const Time &t1,const Time &t2);
    bool operator>(const Time &t2);
    void tick();
};
void Time::tick()
{
    if(second<59)
        second++;
    else
    {
        second=0;
        if(minute<59)
            minute++;
        else
        {
            minute=0;
            if(hour<23)
            {
                hour++;
            }
            else
            {
                hour=0;
            }
        }
    }
}
bool Time::operator>(const Time &t2)
{
    if(hour>t2.hour)
      return 1;
    else if(hour==t2.hour)
    {
        if(minute>t2.minute)
            return 1;
        else
        {
            if(this->minute==t2.minute)
            {
                if(this->second>t2.second)
                    return 1;
                else return 0;
            }
        }
    }

     return 0;
}

bool operator==(const Time &t1,const Time &t2)
{
    if(t1.hour==t2.hour&&t1.minute==t2.minute&&t1.second==t2.second)
        return 1;
    else return 0;
}
void Time::dispiayTime()
{
    printf("%02d:%02d:%02d\n",hour,minute,second);

}
Time::Time(int h,int m,int s):hour(h),minute(m),second(s)
{
    if(h>24||h<0) hour =12;
    if(m>60||m<0)minute =0;
    if(s>60||s<0) second =0;

}
int main()
{
    int a,b,c;
    cin>>a>>b>>c;
    Time T1(a,b,c);
    cin>>a>>b>>c;
    Time T2(a,b,c);
//    T1.dispiayTime();
//    T2.dispiayTime();
    if(T1>T2)
        cout<<"The begin time is not earlier than the end time!"<<endl;
    else
    while(T2>T1||T1==T2)
    {
        T1.dispiayTime();
        T1.tick();
    }
   return 0;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值