Network Saboteur FZU - 1346

Network Saboteur

  FZU - 1346 

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B). 
Input
The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).

Output
Output must contain a single integer -- the maximum traffic between the subnetworks.
Sample Input
3
0 50 30
50 0 40
30 40 0
Sample Output
90

题解+解析:

#include <iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include <cstring>
#include <string>
#define INF 0x7f7f7f7f
typedef long long ll;
using namespace std;
bool vis[50];
int a[30][30];
int ans = -1;
int t;
void dfs(int c)
{
	if (c == t)//分配完节点,计算距离。
	{
		int count = 0;
		for (int i = 0; i < t; i++)
		{
			if (vis[i])
			{
				for (int j = 0; j < t; j++)
				{
					if (!vis[j])
					{
						count += a[i][j];
					}
				}
			}
		}
		if (count > ans)
		{
			ans = count;
			return;
		}
		else
		{
			return;
		}
	}
	
	vis[c] = true;//每个节点有两种可能
	dfs(c+1);
	if (c==0)//把第一个节点放进另一个集合里是重复的,剪枝
	{
		return;
	}
	vis[c] = false;
	dfs(c+1);
}
int main()
{
	while (scanf("%d", &t) != EOF)
	{
		ans = -1;
		memset(vis, 0, sizeof(vis));
		for (int i = 0; i < t; i++)
		{
			for (int j = 0; j < t; j++)
			{
				scanf("%d", &a[i][j]);
			}
		}
		dfs(0);//分配节点。
		printf("%d\n", ans);
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值