Max Sum HDU1003

Max Sum

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

AC代码

#include<bits/stdc++.h>

using namespace std;
typedef long long ll;
const int maxn = 1050;
const int INF = 0x3f3f3f3f;
#define PI 3.1415927

int a;
int t;
int n, m;
struct Node
{
    int x, y, sum;
};
Node ans, tt;//ans存的是答案,tt存的是临时数据
int main()
{
    scanf("%d", &t);
    getchar();//读掉多余的换行

    int a=1;
    while(t--)
    {
        ans = {1, 1, -INF};//初始化两个结构体,-INF是为了防止整个数列全部是负数
        tt = {1,0,0};
        scanf("%d", &n);
        for(int i = 1; i <= n; ++i)
        {
            int temp;
            scanf("%d", &temp);
            tt.sum += temp;//录入一个新的变量,临时数据的sum加上新变量的值
            ++tt.y;//录入一个新的变量,右边界+1
            if(tt.sum > ans.sum)//临时变量里的sum>答案里的sum,更新答案
            {
                ans = tt;
            }
            if(tt.sum < 0)//当临时变量里的sum<0,易知该数列+后面任何一个数列(有可能只有一个数)都只会使后面哪个数列的值变小,
            {             //所以可以直接舍去前面的数列,改变左边界继续计算后面的数列
                tt.sum = 0;
                tt.x = i+1;
                tt.y = i;
            }
        }
        printf("Case %d:\n",a++);
        printf("%d %d %d\n", ans.sum, ans.x, ans.y);
        if(t!=0)
            printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值