Layout POJ - 3169

Layout

POJ - 3169

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

AC代码

//#include<bits/stdc++.h>
#define _CRT_SBCURE_NO_DEPRECATE
#include <set>
#include <map>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
//#define UP(i,x,y) for(int i=x;i<=y;i++)
//#define DOWN(i,x,y) for(int i=x;i>=y;i--)
#define sdddd(x,y,z,k) scanf("%d%d%d%d", &x, &y, &z, &k)
#define sddd(x,y,z) scanf("%d%d%d", &x, &y, &z)
#define sdd(x,y) scanf("%d%d", &x, &y)
#define sd(x) scanf("%d", &x)
#define mp make_pair
#define pb push_back
#define lson k<<1
#define rson k<<1|1
#define mid (l+r)/2
#define ms(x, y) memset(x, y, sizeof x)
using namespace std;
typedef long long ll;
//typedef unsigned long long ull;
#define MOD 142857
const int maxn = 10100;
const int INF = 0x3f3f3f3f;
const ll LINF = 0x3f3f3f3f3f3f3f3f;
int n, m, s, t;
int len;
struct road
{
	int u, v, len;
	int next;
	void getvalue(int uu, int vv, int ll, int nn)
	{
	    u = uu; v = vv; len = ll; next = nn;
	}
	road(){}
};
struct node
{
    int v;
    int len;
    int cost;
    node(int v, int l, int c):v(v),len(l),cost(c){}
    friend bool operator <(node a, node b)
    {
        return a.len>b.len;
    }
};
road G[maxn*5];
int h[maxn];
int mx = -INF;
int d[maxn];
int bellman_ford()
{
    int res;
    fill(d, d+n+1, INF);
    d[1] = 0;
    for(int i = 0; i < n; i++)
    {
        for(int k = 0; k < len; k++)
        {
            road e = G[k];
            if(d[e.v] > d[e.u] + e.len)
            {
                d[e.v] = d[e.u] + e.len;
                if(i == n-1)
                {
                    return 0;
                }
            }
        }
    }
    return 1;
}
int main()
{
	//freopen("out.txt", "w", stdout);
    while(~sddd(n, m, t))
    {
        int ta, tb, tc;
        len = 0;
        fill(h, h+n+1, -1);
        for(int i = 0; i < m; i++)
        {
            sddd(ta, tb, tc);
            G[len].getvalue(ta,tb,tc,h[ta]);
            h[ta] = len++;
        }
        for(int i = 0; i < t; i++)
        {
            sddd(ta, tb, tc);
            G[len].getvalue(tb,ta,-tc,h[tb]);
            h[tb] = len++;
        }
//        for(int i = n; i >1; i--)
//        {
//            G[len].getvalue(i, i-1, 0, h[i]);
//            h[i] = len++;
//        }
        int ans;
        ans = bellman_ford();

        if(ans==0)
            puts("-1");
        else{
            if(d[n]==INF)
                puts("-2");
            else
                printf("%d\n",d[n]);
        }
    }

	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值