2019 Multi-University Training Contest 2 Longest Subarray HDU6602 (线段树 区间更新)

Longest Subarray

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1513    Accepted Submission(s): 517


 

Problem Description

You are given two integers C,K and an array of N integers a1,a2,...,aN. It is guaranteed that the value of ai is between 1 to C.

We define that a continuous subsequence al,al+1,...,ar(l≤r) of array a is a good subarray if and only if the following condition is met:

∀x∈[1,C],∑i=lr[ai=x]=0or∑i=lr[ai=x]≥K



It implies that if a number appears in the subarray, it will appear no less than K times.

You should find the longest good subarray and output its length. Or you should print 0 if you cannot find any.

 

 

Input

There are multiple test cases.

Each case starts with a line containing three positive integers N,C,K(N,C,K≤105).

The second line contains N integer a1,a2,...,aN(1≤ai≤C).

We guarantee that the sum of Ns, the sum of Cs and the sum of Ks in all test cases are all no larger than 5×105.

 

 

Output

For each test case, output one line containing an integer denoting the length of the longest good subarray.

 

 

Sample Input

 

7 4 2 2 1 4 1 4 3 2

 

 

Sample Output

 

4

 

 

Source

2019 Multi-University Training Contest 2

 思路:根据题意,我们可以知道当第i个位置出现值v的时候,我们设之前第一个出现v的位置是y,之前第k个出现v的位置是x,那么对于值v来说满足条件的两个区间是(y+1,i-1)和(1,x-1),根据此我们来建立线段树,维护每个位置当前满足条件的v的个数,当其等于C时,说明可以选择。

AC代码:

#include<bits/stdc++.h>
//#include<vector>
//#include<iostream>
using namespace std;
#define rep(i,a,b) for(int i=a;i<=b;++i)
#define per(i,a,b) for(int i=a;i>=b;--i)
#define ms(a,b) memset(a, b, sizeof(a))
typedef long long ll;
const int MAXN = 1e5 + 50;
const int INF = 0x3f3f3f3f;
const ll  LINF = 0x3f3f3f3f3f3f3f3f;
template <class T>
inline bool scan_d(T &ret) {
    char c; int sgn;
    if (c = getchar(), c == EOF) return 0;
    while (c != '-' && (c<'0' || c>'9')) c = getchar();
    sgn = (c == '-') ? -1 : 1;
    ret = (c == '-') ? 0 : (c - '0');
    while (c = getchar(), c >= '0'&&c <= '9') ret = ret * 10 + (c - '0');
    ret *= sgn;
    return 1;
}
int t, n, m, c, k;
int a[MAXN], now[MAXN];
vector<int> pos[MAXN];
struct node{
    int mx;
    int lz;
}Tree[MAXN*4];
void push_up(int rt){
    Tree[rt].mx = max(Tree[rt<<1].mx, Tree[rt<<1|1].mx);
}
void push_down(int rt){
    if(Tree[rt].lz){
        Tree[rt<<1].mx += Tree[rt].lz;
        Tree[rt<<1|1].mx += Tree[rt].lz;
        Tree[rt<<1].lz += Tree[rt].lz;
        Tree[rt<<1|1].lz += Tree[rt].lz;

        Tree[rt].lz = 0;
    }
}
void built(int rt, int l, int r){
    Tree[rt].lz = 0;
    Tree[rt].mx = 0;
    if(l == r){
        return;
    }
    int mid = (l+r)/2;
    built(rt<<1, l, mid);
    built(rt<<1|1, mid+1, r);
    push_up(rt);
}
void update(int rt, int l, int r, int a, int b, int val){
    if(a > b) return;
    if(a <= l && r <= b){
        Tree[rt].lz += val;
        Tree[rt].mx += val;
        return;
    }
    push_down(rt);
    int mid = (l+r)/2;
    if(mid>=a) update(rt<<1, l, mid, a, b, val);
    if(mid < b) update(rt<<1|1, mid+1, r, a, b, val);
    push_up(rt);
}
int query(int rt, int l, int r) {
    if(l == r) return l;
    int ans = -1, mid = (l + r) >> 1;
    push_down(rt);
    if(Tree[rt<<1].mx == c) ans = query(rt<<1, l, mid);
    else if(Tree[rt<<1|1].mx == c) ans = query(rt<<1|1, mid + 1, r);
    return ans;
}
int main() {
    while(~scanf("%d%d%d", &n, &c, &k)){
        int ta;
        rep(i, 1, c){
            pos[i].clear();
            pos[i].push_back(0);
        }
        rep(i, 1, n){
            scan_d(a[i]);
            pos[a[i]].push_back(i);
        }
        int ans = 0;
        built(1,1,n);
        rep(i, 1, c){
            pos[i].push_back(n+1);
            update(1,1,n,pos[i][0]+1,pos[i][1]-1, 1);
            now[i] = 0;
        }
        rep(i, 1, n){
            int t = a[i];

            update(1,1,n,pos[t][now[t]]+1, pos[t][now[t]+1]-1, -1);
            if(now[t] >= k) update(1,1,n,1, pos[t][now[t]-k+1], -1);
            now[t]++;
            update(1,1,n,pos[t][now[t]]+1, pos[t][now[t]+1]-1, 1);
            if(now[t] >= k) update(1,1,n,1, pos[t][now[t]-k+1], 1);

            int tmp = query(1,1,n);
            if(tmp!=-1)
                ans = max(ans, i-tmp+1);
        }
        printf("%d\n", ans);
    }

    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值