背包—01

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

 

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

 

Sample Input

 

15 101 2 3 4 55 4 3 2 1

 

Sample Output

 

14

 
#include <iostream>
using namespace std;
 
int main()
{
int nCases;
int nPack, nMaxVolume;
int weight[1002], value[1002];
int record[1002];
    //freopen("input.txt", "r", stdin);
    scanf("%d", &nCases);
    while(nCases--)
    {
        memset(record, 0, sizeof(record));
        scanf("%d %d", &nPack, &nMaxVolume);
        for(int i=0; i<nPack; ++i)
            scanf("%d", &value[i]);
        for(int i=0; i<nPack; ++i)
            scanf("%d", &weight[i]);
        for(int i=0; i<nPack; ++i)
            for(int j=nMaxVolume; j>=weight[i]; --j)
            {
                if(record[j-weight[i]]+value[i] > record[j])
                    record[j] = record[j-weight[i]]+value[i];
            }
        printf("%d\n", record[nMaxVolume]);
    }
    return 0;
}
using namespace std;
 
int main()
{
int nCases;
int nPack, nMaxVolume;
int weight[1002], value[1002];
int record[1002];
    //freopen("input.txt", "r", stdin);
    scanf("%d", &nCases);
    while(nCases--)
    {
        memset(record, 0, sizeof(record));
        scanf("%d %d", &nPack, &nMaxVolume);
        for(int i=0; i<nPack; ++i)
            scanf("%d", &value[i]);
        for(int i=0; i<nPack; ++i)
            scanf("%d", &weight[i]);
        for(int i=0; i<nPack; ++i)
            for(int j=nMaxVolume; j>=weight[i]; --j)
            {
                if(record[j-weight[i]]+value[i] > record[j])
                    record[j] = record[j-weight[i]]+value[i];
            }
        printf("%d\n", record[nMaxVolume]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值