POJ 2184 Cow Exhibition

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 
 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

题意:每只牛都有一个S属性和F属性,要求从给出的N头牛中,选出使S属性和F属性的和最大,并且两种属性之和都大于0

解题思路:明显的背包问题,这里因为数据太大,开不了2维的DP数组,所以不能用二维费用背包来做,但是我们可以把它转成01背包来做,我们可以将具有的S属性当做容量,对应的F属性当做价值来求解。但是因为有负值,所以需要把给的值加上1e5,这样可以保证不为负数。具体实现可以看下面的代码

#include <bits/stdc++.h>
using namespace std;
const int maxn=2e5+10;
typedef long long ll;
const int INF=0x3f3f3f3f;
int n;
int dp[maxn];
int s[maxn],f[maxn];
int main(int argc, char const *argv[])
{
    int k=1e5;
    scanf("%d",&n);
    int sum1=0,sum2=0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&s[i],&f[i]);
    }
    memset(dp,-INF,sizeof(dp));
    dp[k]=0;
    for(int i=1;i<=n;i++)
    {
        if(s[i]>0)
        {
            for(int j=2e5;j>=s[i];j--)//正值需要逆序(01背包)
            {
                if(dp[j-s[i]]>-INF)
                {
                    dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
                }
            }
        }
        else//负值需要顺序(这样可以保证循环时,是上一轮留下的)
        {
            for(int j=s[i];j<=2e5;j++)
            {
                if(dp[j-s[i]]>-INF)
                {
                    dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
                }
            }
        }
    }
    int M=0;
    for(int i=1e5;i<=2e5;i++)
    {
        if(dp[i]>=0&&dp[i]+i-1e5>M)
        {
            M=dp[i]+i-1e5;
        }
    }
    cout<<M<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值