NYOJ-791 Color the fence (贪心)

Color the fence

时间限制: 1000 ms  |  内存限制:65535 KB
难度: 2
 
描述

Tom has fallen in love with Mary. Now Tom wants to show his love and write a number on the fence opposite to 

Mary’s house. Tom thinks that the larger the numbers is, the more chance to win Mary’s heart he has.

Unfortunately, Tom could only get V liters paint. He did the math and concluded that digit i requires ai liters paint. 

Besides,Tom heard that Mary doesn’t like zero.That’s why Tom won’t use them in his number.

Help Tom find the maximum number he can write on the fence.

 
输入
There are multiple test cases.
Each case the first line contains a nonnegative integer V(0≤V≤10^6).
The second line contains nine positive integers a1,a2,……,a9(1≤ai≤10^5).
输出
Printf the maximum number Tom can write on the fence. If he has too little paint for any digit, print -1.
样例输入
5
5 4 3 2 1 2 3 4 5
2
9 11 1 12 5 8 9 10 6
样例输出
 
  
55555 33

解题思路:这道题一开始我的思路是:既然要使数字最大,那么让他的位数最大就好了,按照他们的消耗排完序,然后每次都取最少消耗的那个数字,v-a[0],直到v<0的时候。就找到位数最多的时候了。但是没ac出来,看了题解才恍然大悟。然而最长可以不仅仅是由最小的数得到。如:V=5,array={2,3,24,32,31,14,15,7,9}, 虽然可以得到最长长度是2,且由除以2可得到结果11,但是最优的结果却是21。所以只要我们能 保证我们得到的高位数字比选择最小的数所得高位数字大并且位数相等即可。
付ac代码:

#include <stdio.h>

int main(void)
{
    int V;
    while (~scanf("%d", &V))
    {
        int array[10],i;
        int min = 10001;
        for (i = 1; i <= 9; i++)
        {
            scanf("%d", &array[i]);
            if (array[i] <= min)
            {
                min = array[i];
            }
        }

        if (min > V)
        {
            printf("-1\n");
            continue;
        }
        int bit = V / min;
        while(bit--)
        {
            for (int j = 9; j >= 1; j--)
            {
                if (V >= array[j] && (V - array[j] )/ min == bit)
                {
                    printf("%d", j);
                    V -= array[j];
                    break;
                }
            }
        }
        putchar('\n');
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值