Red and Black bfs

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

 

 

Sample Input

 

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#.. ..#..#..#..

..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

 

 

Sample Output

 

45

59

6

13

#include <iostream>
#include <queue>
using namespace std;
struct Node {
    int x,y,step;
};
int n,m;
char a[50][50];
int c[4][2]= {{0,1},{1,0},{0,-1},{-1,0}};
void bfs(int i,int j) {
    int ans=1;//初值设为1
    queue<Node> q;
    Node fr,ne;
    fr.x=i;
    fr.y=j;
    fr.step=1;
    a[i][j]='#';
    q.push(fr);
    while(!q.empty()) {
        fr=q.front();
        q.pop();
        for(int k=0; k<4; k++) {
            ne.x=fr.x+c[k][0];
            ne.y=fr.y+c[k][1];
            //ne.step=fr.step+1;//代表走了多少步 
            if(ne.x<m&&ne.y<n&&ne.x>=0&&ne.y>=0&&a[ne.x][ne.y]!='#') {
                ans++;//表示搜了多少点 
                q.push(ne);
                a[ne.x][ne.y]='#';
            }
        }
    }
    //printf("%d\n",fr.step);
    printf("%d\n",ans);
}
int main() {
    while(~scanf("%d%d",&n,&m)&&(n||m)) {
        int p1,p2;
        for(int i=0; i<m; i++) {
            scanf("%s",a[i]);
        }
        for(int i=0; i<m; i++)
            for(int j=0; j<n; j++) {
                if(a[i][j]=='@') {
                    p1=i,p2=j;
                    break;
                }
            }
        bfs(p1,p2);
// printf("%d\n",ans);
    }
    return 0;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值