BFS入门-Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.   

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)  


Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output

45
59
6
13
题解

基础BFS。人可以上下左右移动,红砖就是墙,黑砖可以重复走。将起点放入队列,上下左右四个方向,是没走过的黑砖就将它标记并计数。结果就是人能够到达的所有黑砖数量。

代码

#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
struct node
{
int x;
int y;
}now,Next;
int main()
{
char s[30][30]={0};
int use[30][30]={0};
int dir[4][2]={-1,0,0,-1,1,0,0,1};//四个方向 
int n,m,i,j;
while(scanf("%d%d",&n,&m))
{
if(n==0&&m==0)break;
queue<node> qu;
memset(use,0,sizeof(use));
int count=1;
for(i=0;i<m;i++)scanf("%s",s[i]);
for(i=0;i<m;i++)//搜寻起点 
{
for(j=0;j<n;j++)
   {
     if(s[i][j]=='@')
     {
      now.x=i;
       now.y=j;
     use[i][j]=1;
                }
     }
}
        qu.push(now);//将起点放入队列 
        while(qu.size())
        {
           now=qu.front();
           qu.pop();
           for(i=0;i<4;i++)
           {
          Next.x=now.x+dir[i][0];
          Next.y=now.y+dir[i][1];
          if(s[Next.x][Next.y]=='.'&&use[Next.x][Next.y]==0&&Next.x>=0&&Next.x<m&&Next.y>=0&&Next.y<n)//判读是否在地图中并且是没到达过的黑砖 
          {
              use[Next.x][Next.y]=1;//标记该黑砖                                               
                   count++;//计数                                                       
                   qu.push(Next);                                              
         }
            }
        }
        printf("%d\n",count); 
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值