D - Walk and Teleport(贪心)

Problem Statement

There are NN towns on a line running east-west. The towns are numbered 11 through NN, in order from west to east. Each point on the line has a one-dimensional coordinate, and a point that is farther east has a greater coordinate value. The coordinate of town ii is XiXi.

You are now at town 11, and you want to visit all the other towns. You have two ways to travel:

  • Walk on the line. Your fatigue level increases by AA each time you travel a distance of 11, regardless of direction.

  • Teleport to any location of your choice. Your fatigue level increases by BB, regardless of the distance covered.

Find the minimum possible total increase of your fatigue level when you visit all the towns in these two ways.

Constraints

  • All input values are integers.
  • 2≤N≤1052≤N≤105
  • 1≤Xi≤1091≤Xi≤109
  • For all i(1≤i≤N−1)i(1≤i≤N−1), Xi<Xi+1Xi<Xi+1.
  • 1≤A≤1091≤A≤109
  • 1≤B≤1091≤B≤109

Input

The input is given from Standard Input in the following format:

NN AA BB
X1X1 X2X2 ...... XNXN

Output

Print the minimum possible total increase of your fatigue level when you visit all the towns.


Sample Input 1 Copy

Copy

4 2 5
1 2 5 7

Sample Output 1 Copy

Copy

11

From town 11, walk a distance of 11 to town 22, then teleport to town 33, then walk a distance of 22 to town 44. The total increase of your fatigue level in this case is 2×1+5+2×2=112×1+5+2×2=11, which is the minimum possible value.


Sample Input 2 Copy

Copy

7 1 100
40 43 45 105 108 115 124

Sample Output 2 Copy

Copy

84

From town 11, walk all the way to town 77. The total increase of your fatigue level in this case is 8484, which is the minimum possible value.


Sample Input 3 Copy

Copy

7 1 2
24 35 40 68 72 99 103

Sample Output 3 Copy

Copy

12

题意:
有n个城镇在x轴上(每个城镇的位置记为a[i]),你开始时在1出。你可以有两种方式移动

1,每次移动1个单位,花费为A;

2,每次可以移动到任意处花费为B;

问你浏览所有的城镇的最小花费。

代码:
 

#include<bits/stdc++.h>
#define ll long long
using namespace std;
ll s[100009];
int main()
{
    ll n,a,b;
    scanf("%lld%lld%lld",&n,&a,&b);
    for(ll i=1;i<=n;i++)
    {
        scanf("%lld",&s[i]);
    }
    ll sum=0;
    for(ll i=2;i<=n;i++)
    {
        ll x=s[i]-s[i-1];
        sum+=min(a*x,b);
    }
    cout<<sum<<endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值