AtCoder Regular Contest 067,D - Walk and Teleport(简单贪心,该类题目注意对给出数据排序)

题目描述:

                                  D - Walk and Teleport

Time Limit: 2 sec / Memory Limit: 256 MB

Score : 500500 points

Problem Statement

There are NN towns on a line running east-west. The towns are numbered 11 through N,

in order from west to east. Each point on the line has a one-dimensional coordinate, and a

point that is farther east has a greater coordinate value. The coordinate of town ii is XiXi.

You are now at town 11, and you want to visit all the other towns. You have two ways to travel:

  • Walk on the line. Your fatigue level increases by AA each time you travel a distance of 1,

  • regardless of direction.

  • Teleport to any location of your choice. Your fatigue level increases by B, regardless of

  • the distance covered.

Find the minimum possible total increase of your fatigue level when you visit all the towns in

these two ways.

Constraints

  • All input values are integers.
  • 2≤N≤105
  • 1≤Xi≤109
  • For all i(1≤i≤N−1)i(1≤i≤N−1), Xi<Xi+1
  • 1≤A≤109
  • 1≤B≤109

Input

The input is given from Standard Input in the following format:

N A B
X1 X2 ...... XN

Output

Print the minimum possible total increase of your fatigue level when you visit all the towns.

Sample Input 1 

4 2 5
1 2 5 7

Sample Output 1

11

From town 11, walk a distance of 11 to town 22, then teleport to town 33, then walk a distance

of 22 to town 44. The total increase of your fatigue level in this case is 2×1+5+2×2=11,

which is the minimum possible value.

Sample Input 2 Copy

Copy

7 1 100
40 43 45 105 108 115 124

Sample Output 2 Copy

Copy

84

From town 11, walk all the way to town 77. The total increase of your fatigue level in this case

is 8484, which is the minimum possible value.

Sample Input 3 Copy

Copy

7 1 2
24 35 40 68 72 99 103

Sample Output 3 Copy

Copy

12

Visit all the towns in any order by teleporting six times. The total increase of your fatigue level in

this case is 1212, which is the minimum possible value.

题意:

           X轴上N个小镇1~N,每个小镇一个坐标,某人从1号镇出发,遍历所有的小镇,

每次后移有2种方案:

                 方案1:每次走一单位花费A代价;

                 方案2:跳跃到任意一个小镇,花费B代价。

求遍历完所有小镇所花费的最小代价。

思路:

       这题思路简单,贪心即可,每次选择代价较小的一种方案。只是联想到这种“X轴”类型的题目

有时候需要的是从小到大的坐标,但题目给出的坐标并不一定是从小到大的(当然该题给出数据是排好序的),

所以注意排序。

代码实现:

#include<bits/stdc++.h>
#define LL long long
using namespace std;
const int N=2e5+100;
const int mod=1e9+7;
LL a[N];
int main()
{
	LL n,A,B;
	while(cin>>n>>A>>B)
	{
		for(int i=1;i<=n;i++)cin>>a[i];
		sort(a+1,a+1+n);
		LL ans=0;
		for(int i=1;i<n;i++)
		{
			LL tmp=(a[i+1]-a[i])*A;
			ans+=min(tmp,B);
		}
		cout<<ans<<endl;
	}
	return 0;
}

The end;

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
代码下载:完整代码,可直接运行 ;运行版本:2022a或2019b或2014a;若运行有问题,可私信博主; **仿真咨询 1 各类智能优化算法改进及应用** 生产调度、经济调度、装配线调度、充电优化、车间调度、发车优化、水库调度、三维装箱、物流选址、货位优化、公交排班优化、充电桩布局优化、车间布局优化、集装箱船配载优化、水泵组合优化、解医疗资源分配优化、设施布局优化、可视域基站和无人机选址优化 **2 机器学习和深度学习方面** 卷积神经网络(CNN)、LSTM、支持向量机(SVM)、最小二乘支持向量机(LSSVM)、极限学习机(ELM)、核极限学习机(KELM)、BP、RBF、宽度学习、DBN、RF、RBF、DELM、XGBOOST、TCN实现风电预测、光伏预测、电池寿命预测、辐射源识别、交通流预测、负荷预测、股价预测、PM2.5浓度预测、电池健康状态预测、水体光学参数反演、NLOS信号识别、地铁停车精准预测、变压器故障诊断 **3 图像处理方面** 图像识别、图像分割、图像检测、图像隐藏、图像配准、图像拼接、图像融合、图像增强、图像压缩感知 **4 路径规划方面** 旅行商问题(TSP)、车辆路径问题(VRP、MVRP、CVRP、VRPTW等)、无人机三维路径规划、无人机协同、无人机编队、机器人路径规划、栅格地图路径规划、多式联运运输问题、车辆协同无人机路径规划、天线线性阵列分布优化、车间布局优化 **5 无人机应用方面** 无人机路径规划、无人机控制、无人机编队、无人机协同、无人机任务分配 **6 无线传感器定位及布局方面** 传感器部署优化、通信协议优化、路由优化、目标定位优化、Dv-Hop定位优化、Leach协议优化、WSN覆盖优化、组播优化、RSSI定位优化 **7 信号处理方面** 信号识别、信号加密、信号去噪、信号增强、雷达信号处理、信号水印嵌入提取、肌电信号、脑电信号、信号配时优化 **8 电力系统方面** 微电网优化、无功优化、配电网重构、储能配置 **9 元胞自动机方面** 交通流 人群疏散 病毒扩散 晶体生长 **10 雷达方面** 卡尔曼滤波跟踪、航迹关联、航迹融合

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值