Y - Bitset

Give you a number on base ten,you should output it on base two.(0 < n < 1000)
Input
For each case there is a postive number n on base ten, end of file.
Output
For each case output a number on base two.
Sample Input
1
2
3
Sample Output
1
10
11

#include<stdio.h>
#define maxn 100000
int main()
{
    int x;
    int a[maxn];
    int count,i,n;
    while(scanf("%d",&x)==1)
    {
    for(i=0; ; i++)
    {
        n=0;
        n=x % 2;
        a[i] = n;
        x = (x-n)/2;
        count = i;
        if (x<1)
        break;
    }
    for(i=count; i>=0; i--)
        printf("%d",a[i]);
    printf("\n");
    }
    return 0;   
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值