1028 人口普查 (20 分)——输入输出问题,集合,排序,内部类

1028 人口普查 (20 分)——输入输出问题,集合,排序,内部类

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:
输入在第一行给出正整数 N,取值在(0,10^​5​​ ];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John

public class Main {
static BufferedReader in=new BufferedReader(new InputStreamReader(System.in));
public static void main(String[] args) throws IOException {
	String nS=in.readLine();
	LinkedList<Person> list=new LinkedList<>();
	int N=Integer.valueOf(nS);
	int sum=0;
	String[] tmp=null;
	for(int i=0;i<N;i++) {
		tmp=in.readLine().split(" ");
		String name=tmp[0];
		tmp=tmp[1].split("/");
		double birth=Integer.valueOf(tmp[0])+Integer.valueOf(tmp[1])/12.0+Integer.valueOf(tmp[2])/30.0/12.0;
		if((2014+9/12.0+6/30.0/12.0)-birth<=200&&(2014+9/12.0+6/30.0/12.0)>=birth) {
			sum++;
			list.add(new Person(name, birth));
		}
	}
	Collections.sort(list, new Comp());
	System.out.println(sum+" "+list.get(list.size()-1).name+" "+list.get(0).name);
}
static class Comp implements Comparator<Person>{

	@Override
	public int compare(Person o1, Person o2) {
		// TODO Auto-generated method stub
		return o1.birth-o2.birth>0?-1:1;
	}
	
}
static class Person{
	String name;
	double birth;
	public Person(String name, double birth) {
		super();
		this.name = name;
		this.birth = birth;
	}
	
}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值