问题 1096: Minesweeper

 

题目描述

Minesweeper Have you ever played Minesweeper? This cute little game comes with a certain operating system whose name we can't remember. The goal of the game is to find where all the mines are located within a M x N field. The game shows a number in a square which tells you how many mines there are adjacent to that square. Each square has at most eight adjacent squares. The 4 x 4 field on the left contains two mines, each represented by a ``*'' character. If we represent the same field by the hint numbers described above, we end up with the field on the right: *... .... .*.. .... *100 2210 1*10 1110

输入

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m ( 0 < n, m$ \le$100) which stand for the number of lines and columns of the field, respectively. Each of the next n lines contains exactly m characters, representing the field. Safe squares are denoted by ``.'' and mine squares by ``*,'' both without the quotes. The first field line where n = m = 0 represents the end of input and should not be processed.

输出

For each field, print the message Field #x: on a line alone, where x stands for the number of the field starting from 1. The next n lines should contain the field with the ``.'' characters replaced by the number of mines adjacent to that square. There must be an empty line between field outputs.

样例输入

4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0

样例输出

Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100

提示

来源

假如有一个*(炸弹),那么它的八连通块都得加一,如果一个格子是0则显示“.”。
于是只要找到*然后用另一个数组把它周围都加一,最后两个数组比较一下就好啦。

 

#include<bits/stdc++.h>

using namespace std;

int n,m;
int d[110][110];
char maze[110][110];
int dx[8] = {-1,-1,0,1,1,1,0,-1};
int dy[8] = {0,1,1,1,0,-1,-1,-1};

void add(int x,int y)
{
	for (int i=0;i<8;i++)
	{
		int nx = x + dx[i];
		int ny = y + dy[i];
		if (0<=nx && nx<n && 0<=ny && ny<m && maze[nx][ny]!='*')
			d[nx][ny] += 1;
	}
}

int main()
{
	int k = 1;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		if (n+m==0) break;
		for (int i=0;i<n;i++)
			scanf("%s",maze[i]);
		memset(d,0,sizeof(d));
		for (int i=0;i<n;i++)
			for (int j=0;j<m;j++)
				if (maze[i][j]=='*')
					add(i,j);
		printf("Field #%d:\n",k++);
		for (int i=0;i<n;i++)
		{
			for (int j=0;j<m;j++)
				if (maze[i][j]=='*')
					printf("*");
				else
					printf("%d",d[i][j]);
			printf("\n");
		}
		puts("");
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值