1086 Tree Traversals Again (25 分) 根据先序中序写出后序

 

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题意:

           一开始看的时候以为只给了一种遍历来求后序遍历,其实不然,题目只给出了中序遍历的结果(出栈顺序),其实仔细观察可以发现压栈顺序就是先序遍历,因此题目给出了先序序列和中序序列。 与1020十分相似

思路:

         先根据输入整理出先序遍历和中序遍历序列,然后根据两种遍历即可建树,最后输出后序遍历即可。(在建树的时候对于下标的思考还不那么快的能够推出)

(node[root].lchild=build(prel+1,prel+p2,inl,p1-1);
    node[root].rchild=build(prel+1+p2,prer,p1+1,inr);)

#include<iostream>
#include<vector>
#include<stack>
using namespace std;
const int maxn=100;
vector<int>pre;
vector<int>in;
vector<int>ans;
stack<int>st;
struct Node
{
	int lchild,rchild;
}node[maxn];
int build(int prel,int prer,int inl,int inr)
{
	if(inl>inr)
	return 0;
	int root=pre[prel];
	int p1,p2;
	p1=inl;
	while(in[p1]!=root)
	p1++;
	p2=p1-inl;//左子树的数目
	//下面的系数还要好好想明白 
	node[root].lchild=build(prel+1,prel+p2,inl,p1-1);
	node[root].rchild=build(prel+1+p2,prer,p1+1,inr);
	return root;
}
void postorder(int root)
{
	if(node[root].lchild)
	postorder(node[root].lchild);
	if(node[root].rchild)
	postorder(node[root].rchild);
	ans.push_back(root);
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=0;i<n*2;i++)
	{
		string s;
		cin>>s;
		if(s=="Push")
		{
			int x;
			cin>>x;
			pre.push_back(x);
			st.push(x);
		}
		else
		{
			in.push_back(st.top());
			st.pop();
		}
	}
	int root=build(0,n-1,0,n-1);
	postorder(root);
	for(int i=0;i<ans.size();i++)
	{
		printf("%d",ans[i]);
		if(i<ans.size()-1)
		printf(" ");
	}	
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值