1086 Tree Traversals Again (25分)——C/C++

1086 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Figure 1在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题目大意:

给定一个节点数,Push的顺序是先序输出,而Pop出来的数是中序输出,最后输出后序遍历。该题就是给出先序和中序然后,输出后序,主要思想是栈和递归。
注:我刚开始的思想非常复杂,主要是用链表。然后我看了柳神的代码,不得不说,是真的简洁,然后我就换了思路,写成了c的版本。不多说了先膜拜一下。下面是链接:https://blog.csdn.net/liuchuo/article/details/52181237

代码:

#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;

int preorder[35];//先序
int inorder[35];//中序
int post[35];//后序
int value[35];
int p=0;

void postorder(int root,int start,int end){
	//root为当前子树的根结点在前序preorder中的下标
	//start和end为当前子树的最左边和最右边的结点在中序inorde中的下标
	int i=start;
	if(start>end)
		return;
	while(i<end && inorder[i]!=preorder[root])
		i++;
	postorder(root+1,start,i-1);
	postorder(root+1+i-start,i+1,end);
	post[p++]=preorder[root];
}
int main(){
	int n,i,j=0,t=0;
	char str[5];
	int key=0;
	stack<int> s;
	scanf("%d",&n);
	for(i=0;i<2*n;i++){
		scanf("%s",str);
		if(strlen(str)==4){
			int temp;
			scanf("%d",&temp);
			value[j]=temp;
			preorder[j++]=key;
			s.push(key++);
		}
		else{
			inorder[t++]=s.top();
			s.pop();
		}
	}
	postorder(0,0,n-1);
	printf("%d", value[post[0]]);
    for (int i = 1; i < n; i++)
        printf(" %d",value[post[i]]);
    return 0;

}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

21岁被迫秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值