1047 Student List for Course (25分)

题目

Zhejiang University has 40,000 students and provides 2,500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N ( ≤ 40 , 000 ) N(\le40,000) N(40,000), the total number of students, and K ( ≤ 2 , 500 ) K(\le2,500) K(2,500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C ( ≤ 20 ) C(\le20) C(20) which is the number of courses that this student has registered, and then followed by C C C course numbers. For the sake of simplicity, the courses are numbered from 1 1 1 to K K K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

Sample Output:

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

题目大意

模拟数据库操作,给出学生的选课信息,要求输出每门课的所有选课人姓名。

思路

题目本身并不难,关键是优化的问题,通过这道题我发现了一个技巧(误区),这道题最后输出学生姓名的时候要求排序,所以我的第一反映就是用set去存储,可以自动排序,结果提交超时,后来改用vector,用sort()去排序,惊奇地发现只用了437ms,于是我仔细想了想,set的内部采用的平衡二叉搜索树,在维持二叉树平衡上可能要花较多时间,并且在输出时远不如vector直接通过下标访问,所以这算是一个经验吧,遇到要排序的,还是要优先考虑用sort()

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAXN = 2501;

bool cmp(char *p, char *q){
    return strcmp(p, q) < 0;
}

int main(){
    vector<char*> db[MAXN];
    int n, k;
    scanf("%d %d", &n, &k);
    for(int i=0, t; i<n; i++){
        char *name = new char[5];
        scanf("%s %d", name, &t);
        for(int j=0, num; j<t; j++){
            scanf("%d", &num);
            db[num].push_back(name);
        }
    }
    for(int i=1; i<=k; i++){
        vector<char*> temp = db[i];
        sort(temp.begin(), temp.end(), cmp);
        printf("%d %d\n", i, temp.size());
        for(int j=0; j<temp.size(); j++){
            printf("%s\n", temp[j]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值