1113 Integer Set Partition (25分)

题目

Given a set of N ( > 1 ) N(\gt1) N(>1) positive integers, you are supposed to partition them into two disjoint sets A 1 A_1 A1 and A 2 A_2 A2 of n 1 n_1 n1 and n 2 n_2 n2 numbers, respectively. Let S 1 S_1 S1 and S 2 S_2 S2 denote the sums of all the numbers in A 1 A_1 A1 and A 2 A_2 A2, respectively. You are supposed to make the partition so that ∣ n 1 − n 2 ∣ |n_1-n_2| n1n2 is minimized first, and then ∣ S 1 − S 2 ∣ |S_1-S_2| S1S2 is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N ( 2 ≤ N ≤ 1 0 5 ) N(2\le N\le10^5) N(2N105), and then N N N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2 31 2^{31} 231.

Output Specification:

For each case, print in a line two numbers: ∣ n 1 − n 2 ∣ |n_1-n_2| n1n2 and ∣ S 1 − S 2 ∣ |S_1-S_2| S1S2, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

int main(){
    int n, sum1 = 0, sum2 = 0;
    vector<int> v;
    scanf("%d", &n);
    v.resize(n);
    for(int i=0; i<n; i++)
        scanf("%d", &v[i]);
    sort(v.begin(), v.end());
    for(int i=0; i<n/2; i++)
        sum1 += v[i];
    for(int i=n/2; i<n; i++)
        sum2 += v[i];
    printf("%d %d\n", n%2, sum2-sum1);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值