1114 Family Property (25分)

题目

This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 1000 ) N(\le1000) N(1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k k k C h i l d 1 Child_1 Child1 C h i l d k Child_k Childk $M_{estate} Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person’s parents (if a parent has passed away, -1 will be given instead); k ( 0 ≤ k ≤ 5 ) k(0\le k\le5) k(0k5) is the number of children of this person; C h i l d i Child_i Childi's are the ID's of his/her children; M e s t a t e M_{estate} Mestate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M A V G s e t s AVG_{sets} AVGsets A V G a r e a AVG_{area} AVGarea

where ID is the smallest ID in the family; M is the total number of family members; A V G s e t s AVG_{sets} AVGsets is the average number of sets of their real estate; and A V G a r e a AVG_{area} AVGarea
​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

题目大意

给出家庭成员关系信息,以及家庭房产数量和面积信息,有直系或间接亲属关系的视为同一个家庭,要求输出有多少个家庭,每个家庭的成员数量,平均房产数量和房产面积。

思路

图的连同分量问题,直接dfs遍历,遍历的趟数就是家庭的数量。

代码

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

struct node{
    int sets;
    double area;
    vector<int> link;
}node[10000];

struct output{
    int id, total;
    double avgsets, avgarea;
};

bool visited[10000];
int minid, total, sets;
double area;

void dfs(int root){
    if(root < minid)
        minid = root;
    total++;
    sets += node[root].sets;
    area += node[root].area;
    visited[root] = true;
    for(int i=0; i<node[root].link.size(); i++){
        if(!visited[node[root].link[i]])
            dfs(node[root].link[i]);
    }
}

bool cmp(output o1, output o2){
    if(o1.avgarea != o2.avgarea)
        return o1.avgarea > o2.avgarea;
    else
        return o1.id < o2.id;
}

int main(){
    fill(visited, visited+10000, true);
    int n;
    scanf("%d", &n);
    for(int i=0; i<n; i++){
        int id, fa, ma, k, mest;
        double area;
        scanf("%d%d%d%d", &id, &fa, &ma, &k);
        if(fa != -1){
            node[id].link.push_back(fa), node[fa].link.push_back(id);
            visited[fa] = false;
        }
        if(ma != -1){
            node[id].link.push_back(ma), node[ma].link.push_back(id);
            visited[ma] = false;
        }
        visited[id] = false;
        for(int j=0, child; j<k; j++){
            scanf("%d", &child);
            node[id].link.push_back(child), node[child].link.push_back(id);
            visited[child] = false;
        }
        scanf("%d%lf", &mest, &area);
        node[id].sets += mest;
        node[id].area += area;
    }
    vector<output> ans;
    for(int i=0; i<10000; i++){
        if(!visited[i]){
            minid = 10000, total = 0, sets = 0, area = 0;
            dfs(i);
            output opt;
            opt.id = minid;
            opt.total = total;
            opt.avgsets = sets*1.0/total;
            opt.avgarea = area/total;
            ans.push_back(opt);
        }
    }
    sort(ans.begin(), ans.end(), cmp);
    int t = ans.size();
    printf("%d\n", t);
    for(int i=0; i<t; i++)
        printf("%04d %d %.3lf %.3lf\n", ans[i].id, ans[i].total, ans[i].avgsets, ans[i].avgarea);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值