1114 Family Property (25分)题解

1114 Family Property (25分)

This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child
​1
​​ ⋯Child
​k
​​ M
​estate
​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child
​i
​​ 's are the ID’s of his/her children; M
​estate
​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:
For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG
​sets
​​ AVG
​area
​​

where ID is the smallest ID in the family; M is the total number of family members; AVG
​sets
​​ is the average number of sets of their real estate; and AVG
​area
​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

  • 1.并查集,要求根节点的序号最小,因此在Union的时候要注意下
  • 2.同时,要求一个小团体的数量和总M和Area,这里是设了3个数组:
  • FatherNum[],FatherM[],FahterArea[]
  • 在Union完之后,遍历各节点的时候,将Num,M,Area累加到一个团体的根节点上~~~

上代码~:

#include<iostream>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;
/**
 * 并查集,要求根节点的序号最小~
 * 同时,要求一个小团体的数量和总M和Area,这里是设了3个数组:
 * FatherNum[],FatherM[],FahterArea[]
 * 在Union完之后,遍历各节点的时候,将Num,M,Area累加到一个团体的根节点上~~~
 */ 
int n, father[10000];
set<int> men;
struct node{
    int M, area;
}getMA[10000];
struct node2{
    int id, num;
    double avgM, avgArea;
};
bool cmp(node2 &a,node2 &b){
    return a.avgArea != b.avgArea ? a.avgArea > b.avgArea : a.id < b.id;
}
int findFather(int x){
    int a = x;
    while(x!=father[x])
        x = father[x];
    while(a!=father[a]){
        int temp = a;
        a = father[a];
        father[temp] = x;
    }
    return x;
}
void Union(int a,int b){
    int a_fa = findFather(a);
    int b_fa = findFather(b);
    if(a_fa<b_fa){
        father[b_fa] = a_fa;
    }else{
        father[a_fa] = b_fa;
    }
}
void init(){
    for (int i = 0; i < 10000;i++)
        father[i] = i;
}
int main(){
    cin >> n;
    init();
    int id, fa, mo, k, temp, m, area;
    while(n--){
        cin >> id >> fa >> mo >> k;
        men.insert(id);
        if(fa!=-1){
            Union(id, fa);
            men.insert(fa);
        }
        if(mo!=-1){
            Union(id, mo);
            men.insert(mo);
        }
        while(k--){
            cin >> temp;
            Union(id, temp);
            men.insert(temp);
        }
        cin >> m >> area;
        getMA[id] = node{m,area};
    }
    int  FatherNum[10000] = {0}, FatherM[10000] = {0}, FatherArea[10000] = {0};
    for (auto it = men.begin(); it != men.end();it++){
        FatherNum[findFather(*it)]++;
        FatherM[findFather(*it)] += getMA[*it].M;
        FatherArea[findFather(*it)] += getMA[*it].area;
    }
    vector<node2> ans;
    for (auto it = men.begin(); it != men.end();it++){
        if(FatherNum[*it]>0){
            ans.push_back(node2{*it, FatherNum[*it], 1.0*FatherM[*it]/FatherNum[*it], 1.0*FatherArea[*it]/FatherNum[*it]});
        }
    }
    cout << ans.size() << endl;
    sort(ans.begin(), ans.end(), cmp);
    for (int i = 0; i < ans.size();i++){
        printf("%04d %d %.3f %.3f\n", ans[i].id, ans[i].num,ans[i].avgM,ans[i].avgArea);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值