1150 Travelling Salesman Problem (25分)

题目

The “travelling salesman problem” asks the following question: “Given a list of cities and the distances between each pair of cities, what is the shortest possible route that visits each city and returns to the origin city?” It is an NP-hard problem in combinatorial optimization, important in operations research and theoretical computer science. (Quoted from “https://en.wikipedia.org/wiki/Travelling_salesman_problem”.)

In this problem, you are supposed to find, from a given list of cycles, the one that is the closest to the solution of a travelling salesman problem.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N ( 2 < N ≤ 200 ) N(2\lt N\le200) N(2<N200), the number of cities, and M M M, the number of edges in an undirected graph. Then M M M lines follow, each describes an edge in the format City1 City2 Dist, where the cities are numbered from 1 to N N N and the distance Dist is positive and is no more than 100. The next line gives a positive integer K K K which is the number of paths, followed by K K K lines of paths, each in the format:

n n n C 1 C 2 . . . C n C_1 C_2 ... C_n C1C2...Cn

where n n n is the number of cities in the list, and C i C_i Ci's are the cities on a path.

Output Specification:

For each path, print in a line Path X: TotalDist (Description) where X is the index (starting from 1) of that path, TotalDist its total distance (if this distance does not exist, output NA instead), and Description is one of the following:

  • TS simple cycle if it is a simple cycle that visits every city;
  • TS cycle if it is a cycle that visits every city, but not a simple cycle;
  • Not a TS cycle if it is NOT a cycle that visits every city.

Finally print in a line Shortest Dist(X) = TotalDist where X is the index of the cycle that is the closest to the solution of a travelling salesman problem, and TotalDist is its total distance. It is guaranteed that such a solution is unique.

Sample Input:

6 10
6 2 1
3 4 1
1 5 1
2 5 1
3 1 8
4 1 6
1 6 1
6 3 1
1 2 1
4 5 1
7
7 5 1 4 3 6 2 5
7 6 1 3 4 5 2 6
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 2 5 4 3 1
7 6 3 2 5 4 1 6

Sample Output:

Path 1: 11 (TS simple cycle)
Path 2: 13 (TS simple cycle)
Path 3: 10 (Not a TS cycle)
Path 4: 8 (TS cycle)
Path 5: 3 (Not a TS cycle)
Path 6: 13 (Not a TS cycle)
Path 7: NA (Not a TS cycle)
Shortest Dist(4) = 8

思路

  1. 判断是否连通;
  2. 判断是否是一个环、并且这个环中是否包含所有的城市;
  3. 满足一二条件的已经是TS cycle了,在判断环中包含的城市个数即可,每个城市只出现一次则为TS simple cycle,反之则为TS cycle;

代码

#include <cstdio>
#include <iostream>
#include <cmath>
#include <vector>
using namespace std;

int main(){
    int n, m;
    int mp[201][201];
    bool visited[201];
    scanf("%d%d", &n, &m);
    fill(mp[0], mp[0]+201*201, 20000);
    for(int i=0, v1, v2, w; i<m; i++){
        scanf("%d%d%d", &v1, &v2, &w);
        mp[v1][v2] = mp[v2][v1] = w;
    }
    int k, c;
    int idx, minx = 20000;
    scanf("%d", &k);
    for(int i=1; i<=k; i++){
        scanf("%d", &c);
        int v1, v2, dist = 0, s;
        fill(visited, visited+n+1, false);
        scanf("%d", &v1);
        s = v1;
        visited[v1] = true;
        for(int j=1; j<c; j++){
            scanf("%d", &v2);
            visited[v2] = true;
            dist += mp[v1][v2];
            v1 = v2;
        }
        int cnt = 0;
        for(int j=1; j<=n; j++){
            if(visited[j])
                cnt++;
        }
        if(dist >= 20000){
            printf("Path %d: NA (Not a TS cycle)\n", i);
        }
        else if(s != v2 || cnt < n){
            printf("Path %d: %d (Not a TS cycle)\n", i, dist);
        }
        else{
            if(c == n+1){
                printf("Path %d: %d (TS simple cycle)\n", i, dist);
            }
            else{
                printf("Path %d: %d (TS cycle)\n", i, dist);
            }
            if(dist < minx){
                idx = i, minx = dist;
            }
        }
    }
    printf("Shortest Dist(%d) = %d\n", idx, minx);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值