7-51 两个有序链表序列的合并 (20 分)
已知两个非降序链表序列S1与S2,设计函数构造出S1与S2合并后的新的非降序链表S3。
输入格式:
输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用−1表示序列的结尾(−1不属于这个序列)。数字用空格间隔。
输出格式:
在一行中输出合并后新的非降序链表,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出NULL
。
输入样例:
1 3 5 -1
2 4 6 8 10 -1
输出样例:
1 2 3 4 5 6 8 10
#include <iostream>
#include <vector>
using namespace std;
typedef struct Node {
int data;
Node* next;
}*LinkList;
LinkList creatList() {
LinkList list = new Node({ 0,nullptr }), r = list;
int t;
while (true) {
cin >> t;
if (t == -1)
break;
r->next = new Node({ t,nullptr });
r = r->next;
}
return list;
}
int main() {
LinkList A = creatList(), B = creatList(), C = new Node({ 0,nullptr });
Node* a = A->next, * b = B->next, * c = C;
while (a != nullptr && b != nullptr) {
if (a->data > b->data) {
c->next = b;
b = b->next;
}
else {
c->next = a;
a = a->next;
}
c = c->next;
}
c->next = (a != nullptr ? a : b);
c = C;
if (c->next == nullptr) {
cout << "NULL";
return -1;
}
while (c->next != nullptr) {
c = c->next;
cout << c->data;
if (c->next != nullptr)
cout << " ";
}
return 0;
}