POJ 3126 ——Prime Path(bfs)

给你两个四位的素数a,b。
a可以改变某一位上的数字变成c,但只有当c也是四位的素数时才能进行这种改变。
请你计算a最少经过多少次上述变换才能变成b。
例如:1033 -> 8179 
1033 
1733 
3733 
3739 
3779 
8779 
8179
最少变换了6次。

Input

第一行输入整数T,表示样例数。 (T <= 100) 
每个样例输入两个四位的素数a,b。(没有前导零) 

Output

对于每个样例,输出最少变换次数,如果无法变换成b则输出"Impossible"。

Sample Input

3
1033 8179
1373 8017
1033 1033


Sample Output

6
7
0

#include<iostream>
#include<queue>
using namespace std;
bool isPrim(int x) {
	for (int i = 2; i < x / 2; i++) {
		if (x % i == 0)
			return false;
	}
	return true;
}
int cal[4][2] = { {10000,1000},{1000,100},{100,10},{10,1} }, visited[10001] = {0};
int bfs(const int &a,const int &b) {
	if (a == b)
		return 0;
	queue<int> qe;
	qe.push(a);
	int k=0,len,s;
	visited[a] = 1;
	memset(visited, 0, sizeof(visited));
	while (!qe.empty()) {
		len = qe.size();
		for (int m = 0; m < len; m++) {
			for (int i = 0; i < 4; i++) {
				for (int j = i ? 0 : 1; j < 10; j++) {
					s = qe.front() / cal[i][0] * cal[i][0] + j * cal[i][1] + qe.front() % cal[i][1];
					if (s == b)
						return k + 1;
					if (!visited[s] && isPrim(s)) {
						qe.push(s);
						visited[s] = 1;
					}
				}
			}
			qe.pop();
		}
		k++;
	}
	return 0;
}
int main() {
	int n, a, b;
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> a >> b;
		cout << bfs(a, b) << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值