1060 Are They Equal (25 point(s))

问题描述:

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10^5 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^​100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]…d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

是我最讨厌的编程题类型没错了,真的很烦。

#include<bits/stdc++.h>
using namespace std;
string str = "0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000";
int main(){
	int digit;
	bool flag = true;
	string str1, str2;
	cin >> digit >> str1 >> str2;
	int d1, d2;
	if((d1 = str1.find('.')) == -1) d1 = str1.length();
	if((d2 = str2.find('.')) == -1) d2 = str2.length();
	while(str1[0] == '0'){
		str1.erase(0, 1);
		d1 --;
	}
	while(str2[0] == '0'){
		str2.erase(0, 1);
		d2 --;
	}
	if(str1[0] == '.'){
		d1 = 0;
		while(str1[1] == '0'){
			str1.erase(1, 1);
			d1 --;
		}
	}
	if(str2[0] == '.'){
		d2 = 0;
		while(str2[1] == '0'){
			str2.erase(1, 1);
			d2 --;
		}
	}
	int pos1, pos2;
	if((pos1 = str1.find('.')) != -1) str1.erase(pos1, 1);
	if((pos2 = str2.find('.')) != -1) str2.erase(pos2, 1);
	if(str1.empty()) d1 = 0;
	if(str2.empty()) d2 = 0;
	if(d1 != d2) flag = false;
	str1 += str;
	str2 += str;
	string str3, str4;
	str3 = "0.";
	str4 = "0.";
	for(int i = 0; i< digit; i++){
		str3 += str1[i];
		str4 += str2[i];
		if(str1[i] != str2[i]) flag = false;
	}
	if(flag) cout << "YES " << str3 << "*10^" << d1;
	else cout << "NO " << str3 << "*10^" << d1 << " " << str4 << "*10^" << d2;
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值