【通过PAT复习C++与数据结构】PAT-A 1152 Google Recruitment (20 分)

题目

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.
在这里插入图片描述
prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:
Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:
For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:
20 5
23654987725541023819
Sample Output 1:
49877
Sample Input 2:
10 3
2468024680
Sample Output 2:
404

题目大意

给定一串数字,和一个正整数k,从这串数字中找出第一串k位且位素数的数字。

直觉

把这串数字当作string类型处理能简单很多。然后从这串字符串中暴力枚举每一位k位数(这道题应该只能暴力,我想不到其他方法),然后转换为数字,判断是否为素数。
利用好string.substr()函数,以及stoi()函数,能够让你在处理字符串的时候如鱼得水。

复杂度分析

因为从到到尾只需要枚举每一个开头字母,所有复杂度是O(N)

代码

#include<iostream>
#include<cstring>
using namespace std;
bool isprime(int n){
	if(n<=1)return 0;
	for(int i=2;i*i<=n;++i){
		if(n%i==0)return 0;
	}
	return 1;
} 

int main() {
    int l, k;
    cin >> l >> k;
    string s;
    cin >> s;
    for (int i = 0; i < l - k + 1; i++) {
        string temp = s.substr(i, k);
        int n = stoi(temp);
        if (isprime(n)) {
            cout << temp << endl;
            return 0;
        }
    }
    cout << 404 << endl;
    return 0;
}

提交时间 状态 分数 题目 编译器 耗时 用户
2019/8/24 21:03:26
答案正确
20 1152 C++ (g++) 4 ms Chester
测试点 结果 耗时 内存
0 答案正确 3 ms 424 KB
1 答案正确 4 ms 396 KB
2 答案正确 3 ms 424 KB
3 答案正确 3 ms 384 KB
4 答案正确 4 ms 424 KB
5 答案正确 3 ms 352 KB
6 答案正确 4 ms 384 KB

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值