最小生成树(Agri-Net )(矩阵输入)

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.
Input
The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output
For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28
prim (普利母算法) 加点法
#include<stdio.h>//普利母算法 加点法
#include<string.h>
#define inf 0x3f3f3f3f
int n;
int pre[1001][1001];
int vis[1001],dis[1001];
void prim()
{
    int i,j,k;
    int idex=0;
    int ans=0;
    memset(vis,0,sizeof(vis));
    vis[1]=1;//标记数组  若是此点走过就标记为一  此时是将1点作为路的开头
    for(i=2; i<=n; i++)
        dis[i]=pre[1][i];//将从1到各个点的距离全部储存在dis数组中//若是两个点中没有路那么dis中储存的就是最大值inf
    for(i=2; i<=n; i++)//遍历每个点  因为最小生成树就是要把所有的点全部遍历
    {
        int min=inf;
        idex=0;
        for(j=1; j<=n; j++)//遍历每一个点 找到一个离1最近的点
        {
            if(!vis[j] && dis[j]<min)//而且这个点必须没有被标记过 
            {
                min=dis[j];//维护最小值
                idex=j;
            }
        }
        ans+=min;//将每一步的最小值都加在ans
        //printf("%d\n",ans);
        vis[idex]=1;//将走的点标记
        for(k=1; k<=n; k++)
            if(!vis[k] && dis[k]>pre[idex][k])//更新dis数组//其原则是从目前所在的点出发和之前存在dis中的值作比较将较小的值存起来
                dis[k]=pre[idex][k];
    }
    printf("%d\n",ans);
}
int main()
{
    int u,v,w;
    while(scanf("%d",&n)!=EOF)
    {
        memset(pre,inf,sizeof(pre));//将pre数组初始化为最大值对以后计算有帮助
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                scanf("%d",&pre[i][j]);
            }
        }
        prim();//进入函数
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值