欧拉筛选+唯一分解(模板)

#include<bits/stdc++.h>
#define MAXN 1000005
using namespace std;
typedef long long ll;

ll prime[MAXN];
ll vis[MAXN];
ll cnt;
ll n;
void isprime()
{
    cnt=0;
    for(int i=2;i<=MAXN;i++)
    {
        if(!vis[i])prime[cnt++]=i;
        for(int j=0;j<cnt && i*prime[j]<=MAXN;j++)
        {
            vis[i*prime[j]]=i;
            if(i%prime[j]==0)break;
        }
    }
}
ll solve()
{
    ll sum=n;
    ll ans=1;
    for(int i=0;i<cnt && prime[i]<sum;i++)
    {
        int k=0;
        while(sum%prime[i]==0)
        {
            sum/=prime[i];
            k++;
        }
        ans*=(1+k);
    }
    if(sum>1)ans*=(1+1);//多出一个素数来
    return ans;
}

                             Aladdin and the Flying Carpet

It's said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin's uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

题意:

给你一个长方形面积和一个最小可能的边长,统计有多少种满足面积相等且边长大于等于最小边长的长方形(一定不是正方形)。

根据唯一分解定理,先将a唯一分解,则a的所有正约数的个数为num = (1 + a1) * (1 + a2) *...(1 + ai),这里的ai是素因子的指数,见唯一分解定理,因为题目说了不会存在c==d的情况,因此num要除2,去掉一半,然后枚举小于b的a的约数,拿num减掉就可以了

注意当b*b>n 直接不走不然会超时

#include<bits/stdc++.h>
#define MAXN 1000005
using namespace std;
typedef long long ll;

ll prime[MAXN];
ll vis[MAXN];
ll cnt;
ll n;
void isprime()
{
    cnt=0;
    for(int i=2;i<=MAXN;i++)
    {
        if(!vis[i])prime[cnt++]=i;
        for(int j=0;j<cnt && i*prime[j]<=MAXN;j++)
        {
            vis[i*prime[j]]=i;
            if(i%prime[j]==0)break;
        }
    }
}
ll solve()
{
    ll sum=n;
    ll ans=1;
    for(int i=0;i<cnt && prime[i]<sum;i++)
    {
        int k=0;
        while(sum%prime[i]==0)
        {
            sum/=prime[i];
            k++;
        }
        ans*=(1+k);
    }
    if(sum>1)ans*=(1+1);//多出一个素数来
    return ans;
}
int main()
{
    int t;
    int CS=1;
    isprime();
    ll d;
    scanf("%d",&t);
    ll ans;
    while(t--)
    {
        ans=0;
        ll cnt=0;
        scanf("%lld%lld",&n,&d);
        if(d*d>n)
            ans=0;
        else
        {
            for(int i=1;i<d;i++)if(n%i==0)cnt++;
            ans=solve()/2-cnt;
        }

        
        printf("Case %d: %lld\n",CS++,ans);

    }

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值