Air Raid( 最小路径覆盖)

                                               Air Raid

                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                         Total Submission(s): 6568    Accepted Submission(s): 4363

Problem Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

                                                                    Statistic | Submit | Discuss | Note

题意:

有n个地点和m条道路,道路都是单向的,并且不存在环路,有一些伞兵需要去n个地点视察,伞兵只能沿着路的方向走,问最少需要多少个伞兵。

题解:

最小路径覆盖:用一些(有向的)线段把一些点连接起来,使得这些线段最后组成最多的可连通道路,所有顶点都被覆盖。

先用匈牙利算法得出最大匹配数,也就是给若干个点都安排上了前驱地点,

那么剩下的没有前驱的点都是起点,

起点数就是最小路径覆盖的数目,即5-3=2;

 

邻接表

#include<bits/stdc++.h>
const int maxn=2e5;
using namespace std;
int n,m;
int cnt;
int head[125];
int vis[125];
int pre[125];
struct node
{
    int next;
    int to;
} edge[125*125];
void add(int u,int v)
{
    edge[cnt].to=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
int dfs(int u)
{
    for(int i=head[u]; ~i; i=edge[i].next)
    {
        int t=edge[i].to;
        if(!vis[t])
        {
            vis[t]=1;
            if(pre[t]==0 || dfs(pre[t]))
            {
                pre[t]=u;
                return 1;
            }
        }
    }
    return 0;
}
void init()
{
    cnt=0;
    memset(pre,0,sizeof(pre));
    memset(head,-1,sizeof(head));
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        scanf("%d%d",&n,&m);
        for(int i=1; i<=m; i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            add(u,v);
        }
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))ans++;
        }
        printf("%d\n",n-ans);
    }

    return 0;
}

邻接矩阵

#include<cstring>
#include<cstdio>
#include<cstdlib>
using namespace std;
int const maxn=125;
int n,m;
bool maze[maxn][maxn];
bool vis[maxn];
int pre[maxn];
bool dfs(int x)
{
    for(int i=1; i<=m; i++)
    {
        if(maze[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(!pre[i]||dfs(pre[i]))
            {
                pre[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int a,b;
    int test;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d%d",&m,&n);
        memset(maze,0,sizeof(maze));
        memset(pre,0,sizeof(pre));
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&a,&b);
            maze[a][b]=1;
        }
        int ans=0;
        for(int i=1; i<=m; i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))ans++;

        }
        printf("%d\n",m-ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值