02-线性结构4 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

5 7 5
1 2 3 4 5 6 7
YES
3 2 1 7 5 6 4
NO
7 6 5 4 3 2 1
NO
5 6 4 3 7 2 1
YES
1 7 6 5 4 3 2

思路及步骤:
下面会以上面的例子讲解,入栈序列为1 2 3 4 5 6 7,出栈序列为3 2 1 7 5 6 4,判断是否合法。我们要模拟入栈和出栈。
1、出栈序列的第一个元素3,在入栈序列的排第三个,则必须要入栈三个元素。
2、判断是否溢栈。(7 6 5 4 3 2 1序列,溢栈,不符。)
3、不溢栈,则出栈一个元素。
4、判断第二个元素是否满足。
a、第二个元素在入栈序列的位置号小于第一个元素,则第二个元素已经在堆栈里,出栈一个元素,并判断出栈元素与第二个元素是否相等。
b、第二个元素在入栈序列的位置号大于第一个元素,则需入栈。入栈元素为入栈序列中,第一个元素的入栈序列号+1至第二个元素的入栈序列号。判断是否栈满。再出栈一个元素,判断是否相等。

#include <stdio.h>
#define MAX 1005
int stack[MAX];
int out[MAX];
int check(int M, int N);
int main()
{
	int M, N, K;
	scanf("%d%d%d",&M, &N, &K);
	//i代表第i行 
	for(int i=0; i<K; i++)
	{
		//j代表第i行第j个元素 
		for(int j=1; j<=N; j++)
		{
			scanf("%d", &out[j]) ;
		}
		if(check(M,N))
			printf("YES\n");
		else
			printf("NO\n");
	}
}
int check(int M, int N)
{
	int top=0, po=0;
	for(int k=1; k<=N; k++)
	{
		for(int j=po+1;j<=out[k]; j++)
		{
			stack[top++]=j;
		}
		if(top>M)
		 return 0;
		top--;
		if(stack[top]!=out[k])
			return 0;
		if(po<out[k]) 
			po=out[k];
	}
	return 1;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值