【匈牙利算法】HDU - 1150 Machine Schedule

Machine Schedule HDU - 1150 

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine. 

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

两个机器A、B用来完成任务

其中A有N中模式,B有M种模式

完成任务i 需要A为x模式,或者B为y模式

每次改变模式需要重启一次

问完成所有任务所需要的最少重启次数

 

将每对x,y相连得到一个二分图

每条线代表一个任务

即求二分图的最小点覆盖数

由于二分图中最小点覆盖数=最大匹配数

故可用匈牙利算法

 

跟POJ 3041 异曲同工 

详情可见:https://blog.csdn.net/qq_41037114/article/details/81503939

#include <bits/stdc++.h>
using namespace std;
const int maxn=105;
int G[maxn][maxn],vis[maxn],col[maxn];
int n,m,k;

int dfs(int u)
{
    for(int i=1;i<=m;i++)
    {
        if(G[u][i]&&!vis[i])
        {
            vis[i]=1;
            if(!col[i]||dfs(col[i]))
            {
                col[i]=u;
                return 1;
            }
        }
    }
    return 0;
}

int maxmatch()
{
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i)) ans++;
    }
    return ans;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0) break;
        memset(G,0,sizeof(G));
        memset(col,0,sizeof(col));
        scanf("%d%d",&m,&k);
        for(int i=1;i<=k;i++)
        {
            int p,u,v;
            scanf("%d%d%d",&p,&u,&v);
            G[u][v]=1;
        }
        printf("%d\n",maxmatch());
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值