【数位dp】 HDU - 3709 F - Balanced Number

F - Balanced Number HDU - 3709

A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job 
to calculate the number of balanced numbers in a given range [x, y].

Input

The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 1018).

Output

For each case, print the number of balanced numbers in the range [x, y] in a line.

Sample Input

2
0 9
7604 24324

Sample Output

10
897
问你l-r区间内有多少个数是可以得到一个杠杆,左右两端数字*当前位到杠杆的距离之和相等


#include <bits/stdc++.h>
#define ll long long
using namespace std;
ll dp[20][20][1800];
int a[20];

ll dfs(int pos,int fixloc,int sum,bool limit)
{
    if(pos==0) return sum?0:1;  //到了最后,要是sum==0,代表两边平衡,那么return 1,否则就是错的
    if(sum<0) return 0;  //剪枝,sum是先增再减,要是<0了,就代表之后都小于0,直接return 0
    if(!limit&&dp[pos][fixloc][sum]!=-1) return dp[pos][fixloc][sum];
    int up=limit?a[pos]:9;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        ans+=dfs(pos-1,fixloc,sum+(pos-fixloc)*i,limit&&a[pos]==i);  //sum保存的是当前位两端之差,杠杆左边为加,后边为减
    }
    if(!limit) dp[pos][fixloc][sum]=ans;
    return ans;
}

ll solve(ll x)
{
    int pos=0;
    while(x)
    {
        a[++pos]=x%10;
        x/=10;
    }
    ll ans=0;
    for(int i=1;i<=pos;i++)
    {
        ans+=dfs(pos,i,0,1);  //每一位为杠杆的所有情况之和
    }
    return ans-pos+1;  //pos位中加了pos个0,所以减掉pos-1,0算1个
}

int main()
{
    int T;
    scanf("%d",&T);
    memset(dp,-1,sizeof(dp));
    while(T--)
    {
        ll n,m;
        scanf("%lld%lld",&n,&m);
        printf("%lld\n",solve(m)-solve(n-1));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值