计算某天是星期几-泽勒算法

公式是:

h = (q + 26(m+1)/10 + k + k/4 + j/4 + 5 j)%7

其中:

h是一个星期中的某一天(0为星期六, 1为星期天, 2为星期一, 3为星期二, 4为星期三, 5为星期四, 6为星期五)。

q是某月的第几天。

m是月份, 特别地, 一月和二月分别记为上一年的13月和14月。

j是世纪数(即 year/100)。

k是该世纪的第几年(即year%100)。

注意, 公式中的除法执行的一个整数相除。

下面给出例题以及代码

HDU 2133

What day is it

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7462    Accepted Submission(s): 2130


Problem Description
Today is Saturday, 17th Nov,2007. Now, if i tell you a date, can you tell me what day it is ?
 

Input
There are multiply cases.
One line is one case.
There are three integers, year(0<year<10000), month(0<=month<13), day(0<=day<32).
 

Output
Output one line.
if the date is illegal, you should output "illegal". Or, you should output what day it is.
 

Sample Input
 
 
2007 11 17
 

Sample Output
 
 
Saturday
 

代码:

#include<iostream>
#include<cmath>
#include<sstream>
#include<cstdio>
#include<string>
using namespace std;
int runnian(int x)
{
    if((x%4==0&&x%100!=0)||x%400==0)
        return true;
    else
        return false;
}
int tianshu(int y, int m)
{
    if(m == 2)
    {
        if(runnian(y))
            return 29;
        else
            return 28;
    }
    else if(m==1||m==3||m==5||m==7||m==8||m==10||m==12)
        return 31;
    else
        return 30;
}
int zele(int year, int month, int day)
{
    int h, m;
    int q = day;
    if(month >= 3)
        m = month;
    else
    {
        m = month + 12;
        year--;
    }
    int j = year/100;
    int k = year%100;
    h =  (q + 26*(m+1)/10 + k + k/4 + j/4 + 5*j)%7;
    return h;


}
string Eng[] = {"Saturday", "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" };
int main()
{
    int y, m, d;
    while(cin>>y>>m>>d)
    {
        if(y < 0||m<=0||d<=0||m>12||tianshu(y, m)<d)
        {
            cout<<"illegal"<<endl;
            continue;
        }
        cout<<Eng[zele(y, m, d)]<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值