HDU - 1541 Stars (树状数组)

Stars

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12672 Accepted Submission(s): 4970

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Source

Ural Collegiate Programming Contest 1999

Recommend

LL

题目大意

已知一组坐标按 YX 升序排列,现规定点 Plevel 为横坐标及纵坐标均小于 P 的点之数量,求各个 level 对应的点之数量。

思路

由于输入已经按 Y 升序排列,且不会有相同坐标的点,故一个点的 level 可以转换为输入序列中该点之前所有 X 小于该点的点之数量。由于数据规模大,使用遍历或前缀和数组去寻找这样的点是不现实的,所以想到采用树状数组来存储小于某 X 的点之数量,边输入边查询,每次查询之后再将点插入树状数组。又因为 X 的最大值在接受范围内,所以不用作离散化处理。

AC代码

#include <cstdio>

const int MAXX = 32005;
const int MAXN = 15005;

int tre[MAXX];

inline int lowbit(int x) {
    return x & -x;
}

int sum(int x) {
    int ans = 0;
    for (; x > 0; x -= lowbit(x))
        ans += tre[x];
    return ans;
}

void add(int x) {
    for (; x < MAXX; x += lowbit(x))
        tre[x]++;
}

int main() {
    int n;
    scanf("%d", &n);

    static int l[MAXN];
    for (int i = 1; i <= n; i++) {
        int t;
        scanf("%d%*d", &t);

        l[sum(++t)]++;      //t一定要自增!否则会在sum()中陷入死循环就很惨
        add(t);
    }

    for (int i = 0; i < n; i++)
        printf("%d\n", l[i]);
}

TIPS

  • 正如代码中所提到的,要查询的值需要提前加上1,否则会在 sum() 中陷入死循环;

总结

是一道树状数组的基础题,比较好地体现了树状数组相对于暴力法的优越性。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值