HDU 1541 Stars(树状数组)

34 篇文章 0 订阅
4 篇文章 0 订阅

Stars

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9546 Accepted Submission(s): 3823

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0

题意:计算每颗星星左下边包括了多少颗星星,这个数值就是等级。不超过本身的x,y的坐标。问每种等级有多少颗星星。

题解:题目给的数据按照y排序,相同的y按照x排序,先看x坐标的星星,只看y值相同的星星坐标的x。当一个x输入时,它之后的所有星星的等级肯定都要加一。这点就是树状数组的最基本应用-单点更新。然后get_sum区间求和,它的等级就等于前面已经输入的x坐标在[0,x]区间的星星数量。

代码:

 #include <iostream>
 #include <cstring>
 #include <algorithm>
 #include <cstdio>
 #pragma comment(link,"/STACK: 102400000,102400000")
 using namespace std;
 const int maxn=32005;
 int c[maxn],_rank[maxn];
 int lowbit(int x)///求的是某个点管辖范围;
 {
     return x&(-x);
 }
 int get_sum(int  x)///1~x的区间和 
 {
     int sum=0;
     while(x)
     {
         sum+=c[x];
         x-=lowbit(x);
     }
     return sum;
 }
 void add(int i,int x)///用树状数组对后面节点更新
 {
     while(i<=x)
     {
         c[i]++;
         i +=lowbit(i);
     }
 }

 int main()
 {
    int n;
    while(cin>>n)
    {
       memset(c,0,sizeof(c));
       memset(_rank,0,sizeof(_rank));
       int x,y;
       for(int i=0;i<n;i++)
       {
           cin>>x>>y;
           _rank[get_sum(x+1)]++;
           add(x+1,maxn);
       }
       for(int i=0;i<n;i++)
        cout<<_rank[i]<<endl;
    }
    return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Usher_Ou

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值