Rikka with Stone-Paper-Scissors

http://acm.hdu.edu.cn/showproblem.php?pid=6418

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 448    Accepted Submission(s): 208

Problem Description

Did you watch the movie "Animal World"? There is an interesting game in this movie.

The rule is like traditional Stone-Paper-Scissors. At the beginning of the game, each of the two players receives several cards, and there are three types of cards: scissors, stone, paper. And then in each round, two players need to play out a card simultaneously. The chosen cards will be discarded and can not be used in the remaining part of the game.

The result of each round follows the basic rule: Scissors beat Paper, Paper beats Stone, Stone beats Scissors. And the winner will get 1 point, the loser will lose 1 point, and the points will not change in the case of a draw.

Now, Rikka is playing this game with Yuta. At first, Yuta gets a Scissors cards, b Stone cards and c Paper cards; Rikka gets a′ Scissors cards, b′ Stone cards, c′ Paper cards. The parameters satisfy a+b+c=a′+b′+c′ . And then they will play the game exactly a+b+c rounds (i.e., they will play out all the cards).

Yuta's strategy is "random". Each round, he will choose a card among all remaining cards with equal probability and play it out.

Now Rikka has got the composition of Yuta's cards (i.e., she has got the parameters a,b,c ) and Yuta's strategy (random). She wants to calculate the maximum expected final points she can get, i.e., the expected final points she can get if she plays optimally.

Hint: Rikka can make decisions using the results of previous rounds and the types of cards Yuta has played.

 

 

Input

The first line contains a single number t(1≤t≤104) .

For each testcase, the first line contains three numbers a,b,c and the second line contains three numbers a′,b′,c′(0≤a,b,c,a′,b′,c′≤109,a+b+c=a′+b′+c′>0) .

 

 

Output

For each testcase, if the result is an integer, print it in a line directly.

Otherwise, if the result equals to ab(|gcd(a,b)|=1,b>0, a and b are integers) , output "a /b " (without the quote) in a single line.

 

 

Sample Input

 

4

2 0 0

0 2 0

1 1 1

1 1 1

1 0 0

0 0 1

123 456 789

100 200 1068

Sample Output

 

2

0

-1

3552/19

Source

2018 Multi-University Training Contest 9    

解析:这道题题意就是剪刀石头布算下第二个人赢得期望,谁赢会得一分

假设第一个人石头剪刀布得个数分别为a1,b1,c1,第二个人得分别为a2,b2,c2,第一个人出石头的概率是a1/(a1+b1+c1),以此类推,此时第二个人如果出剪刀,则第二个人赢对应的期望就是a2*(c1-b1)/(a1+b1+c1),以此类推,最后把总的期望加到一起就是结果,   ,,,不过最后需要注意下输出的是分数,且最简,因此分母上不能为负数和零,注意下就好

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
ll gcd(ll x,ll y)
{
    if(y==0)
        return x;
    gcd(y,x%y);
}
int main()
{
    ll t,a1,b1,c1,a2,b2,c2;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld%lld%lld%lld%lld%lld",&a1,&b1,&c1,&a2,&b2,&c2);
        ll x=a2*(c1-b1)+b2*(a1-c1)+c2*(b1-a1);
        ll y=a1+b1+c1;
        ll z=gcd(x,y);
        z=max(z,-z);
        printf("%lld",x/z);
        if(y/z!=1)
            printf("/%lld",y/z);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值