HDU5631 Rikka with Graph

Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has a non-direct graph with n vertices and n+1 edges. Rikka can choose some of the edges (at least one) and delete them from the graph.

Yuta wants to know the number of the ways to choose the edges in order to make the remaining graph connected.

It is too difficult for Rikka. Can you help her?

Input

The first line contains a number T(T≤30)T(T≤30)——The number of the testcases.

For each testcase, the first line contains a number n(n≤100)n(n≤100).

Then n+1 lines follow. Each line contains two numbers u,vu,v , which means there is an edge between u and v.

Output

For each testcase, print a single number.

Sample Input

1
3
1 2
2 3
3 1
1 3

Sample Output

9

Hint

题意

题解:

由于n很小 所以直接枚举1和2的情况 判断不加入某一条边或某两条边成立的个数

AC代码

#include<cstdio>
#include<cstring>
#include<stack>
#include <set>
#include <queue>
#include <vector>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long LL;
const int mod = 1e9+7;
int par[110];
int u[115];
int v[115];
void init(int n){
    for (int i = 1;i <= n; ++i){
        par[i] = i;
    }
}
int fd(int x){
    if (x == par[x]) return par[x];
    return par[x] = fd(par[x]);
}

int main()
{
    int t;
    scanf("%d",&t);
    while (t--){
        int n;
        scanf("%d",&n);
        for (int i = 1;i <= n+1; ++i){
            scanf("%d%d",&u[i],&v[i]);
        }
        int ans;
        int num = 0;
        for (int i = 1; i <= n+1; ++i){
            init(n);
            ans = n;
            for (int j = 1;j <= n+1; ++j){
                if (j!=i){
                    int tx = fd(u[j]);
                    int ty = fd(v[j]);
                    if (tx!=ty){
                        ans--;
                        par[tx] = ty;
                    }
                }
            }if (ans==1) num++;
        }
        ans = n;
        for (int i = 1;i <= n+1; ++i){
            for (int j = i+1; j <= n+1; ++j){
                init(n);
                ans = n;
                for (int k = 1;k <= n+1; ++k){
                    if (k!=i&&k!=j){
                        int tx = fd(u[k]);
                        int ty = fd(v[k]);
                        if (tx!=ty){
                            ans--;
                            par[tx] = ty;
                        }
                    }
                } if(ans==1) num++;
            }
        }
        printf("%d\n",num);
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值